summaryrefslogtreecommitdiffstats
path: root/audio/speex
diff options
context:
space:
mode:
Diffstat (limited to 'audio/speex')
-rw-r--r--audio/speex/speex.SlackBuild6
-rw-r--r--audio/speex/speexdsp-fixbuilds-774c87d.patch36
2 files changed, 41 insertions, 1 deletions
diff --git a/audio/speex/speex.SlackBuild b/audio/speex/speex.SlackBuild
index a7a08ba818..2b467f6384 100644
--- a/audio/speex/speex.SlackBuild
+++ b/audio/speex/speex.SlackBuild
@@ -31,7 +31,7 @@
PRGNAM=speex
VERSION=${VERSION:-1.2rc2}
DSPVERSION=${DSPVERSION:-1.2rc3}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -76,6 +76,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Thanks to the folks at alpine linux for this
+patch -p1 < $CWD/speexdsp-fixbuilds-774c87d.patch
+autoreconf -fi
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/audio/speex/speexdsp-fixbuilds-774c87d.patch b/audio/speex/speexdsp-fixbuilds-774c87d.patch
new file mode 100644
index 0000000000..c02ee29bd7
--- /dev/null
+++ b/audio/speex/speexdsp-fixbuilds-774c87d.patch
@@ -0,0 +1,36 @@
+diff --git a/configure.ac b/configure.ac
+index 2cd2d1e..1de0c23 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -334,6 +334,12 @@ AC_SUBST([USIZE16])
+ AC_SUBST([SIZE32])
+ AC_SUBST([USIZE32])
+
++AS_IF([test "$ac_cv_header_stdint_h" = "yes"], [INCLUDE_STDINT="#include <stdint.h>"],
++ [test "$ac_cv_header_inttypes_h" = "yes"], [INCLUDE_STDINT="#include <inttypes.h>"],
++ [test "$ac_cv_header_sys_types_h" = "yes"], [INCLUDE_STDINT="#include <sys/types.h>"])
++
++AC_SUBST([INCLUDE_STDINT])
++
+ AC_CONFIG_FILES([
+ Makefile libspeexdsp/Makefile doc/Makefile SpeexDSP.spec
+ include/Makefile include/speex/Makefile speexdsp.pc
+diff --git a/include/speex/speexdsp_config_types.h.in b/include/speex/speexdsp_config_types.h.in
+index 02b82fd..5ea7b55 100644
+--- a/include/speex/speexdsp_config_types.h.in
++++ b/include/speex/speexdsp_config_types.h.in
+@@ -1,13 +1,7 @@
+ #ifndef __SPEEX_TYPES_H__
+ #define __SPEEX_TYPES_H__
+
+-#if defined HAVE_STDINT_H
+-# include <stdint.h>
+-#elif defined HAVE_INTTYPES_H
+-# include <inttypes.h>
+-#elif defined HAVE_SYS_TYPES_H
+-# include <sys/types.h>
+-#endif
++@INCLUDE_STDINT@
+
+ typedef @SIZE16@ spx_int16_t;
+ typedef @USIZE16@ spx_uint16_t;