summaryrefslogtreecommitdiffstats
path: root/audio/unsf/unsf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/unsf/unsf.SlackBuild')
-rw-r--r--audio/unsf/unsf.SlackBuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/audio/unsf/unsf.SlackBuild b/audio/unsf/unsf.SlackBuild
index 37a428c753..1a22e47b12 100644
--- a/audio/unsf/unsf.SlackBuild
+++ b/audio/unsf/unsf.SlackBuild
@@ -1,18 +1,23 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for unsf
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
# Upstream hasn't done a proper release since 1.0, we use latest git.
# Use git2targz.sh to prepare source tarballs, when it's time to update.
+# 20211126 bkw: update for v1.1+git20201107
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=unsf
-VERSION=${VERSION:-1.1+git20180608}
+VERSION=${VERSION:-1.1+git20201107}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -22,7 +27,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -50,11 +59,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# upstream forgot to create include/ in the src, revisit this later.
sed -i 's#include/\(libunsf\.h\)#\1#' CMakeLists.txt
@@ -87,4 +93,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE