summaryrefslogtreecommitdiffstats
path: root/audio/volti
diff options
context:
space:
mode:
Diffstat (limited to 'audio/volti')
-rw-r--r--audio/volti/volti.SlackBuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/volti/volti.SlackBuild b/audio/volti/volti.SlackBuild
index 7232e40a32..4d1984e922 100644
--- a/audio/volti/volti.SlackBuild
+++ b/audio/volti/volti.SlackBuild
@@ -23,7 +23,7 @@
PRGNAM=volti
VERSION=${VERSION:-0.2.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -73,6 +73,8 @@ python setup.py install --prefix=/usr --root=$PKG
# Fix bad location of man pages
mv $PKG/usr/share/man $PKG/usr
+sed -i "s|assert dbus.version >= (0, 80, 0)|assert dbus.version >= [0, 80, 0]|g" $PKG/usr/bin/volti
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true