summaryrefslogtreecommitdiffstats
path: root/audio/whipper/whipper.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/whipper/whipper.SlackBuild')
-rw-r--r--audio/whipper/whipper.SlackBuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/audio/whipper/whipper.SlackBuild b/audio/whipper/whipper.SlackBuild
index 11b2248e59..cf4a74d007 100644
--- a/audio/whipper/whipper.SlackBuild
+++ b/audio/whipper/whipper.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for whipper
-# Copyright 2017-2019, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2017-2022, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -86,6 +83,13 @@ python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+make -C man
+mkdir -p $PKG/usr/man/man1
+mv man/*.1 $PKG/usr/man/man1
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG.md COVERAGE HACKING README.md TODO \
$PKG/usr/doc/$PRGNAM-$VERSION