summaryrefslogtreecommitdiffstats
path: root/audio/zita-dpl1/zita-dpl1.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/zita-dpl1/zita-dpl1.SlackBuild')
-rw-r--r--audio/zita-dpl1/zita-dpl1.SlackBuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/audio/zita-dpl1/zita-dpl1.SlackBuild b/audio/zita-dpl1/zita-dpl1.SlackBuild
index 4e472a9682..21702eb4a7 100644
--- a/audio/zita-dpl1/zita-dpl1.SlackBuild
+++ b/audio/zita-dpl1/zita-dpl1.SlackBuild
@@ -6,10 +6,11 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20191202 bkw: updated for v0.3.3
# 20170122 bkw: updated for v0.1.0
PRGNAM=zita-dpl1
-VERSION=${VERSION:-0.1.0}
+VERSION=${VERSION:-0.3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -48,12 +49,8 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
sed -i \
@@ -61,6 +58,8 @@ if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
-e "s,-O2 -ffast-math,$SLKCFLAGS,"
fi
+sed -i 's,pkgconf,pkg-config,' source/Makefile
+
make -C source PREFIX=/usr
make -C source install PREFIX=/usr DESTDIR=$PKG
strip $PKG/usr/bin/$PRGNAM
@@ -75,8 +74,7 @@ mkdir -p $PKG/usr/man/man1
gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING LICENSE README doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install