summaryrefslogtreecommitdiffstats
path: root/audio/zita-dpl1/zita-dpl1.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/zita-dpl1/zita-dpl1.SlackBuild')
-rw-r--r--audio/zita-dpl1/zita-dpl1.SlackBuild44
1 files changed, 30 insertions, 14 deletions
diff --git a/audio/zita-dpl1/zita-dpl1.SlackBuild b/audio/zita-dpl1/zita-dpl1.SlackBuild
index 4e472a9682..57989232a4 100644
--- a/audio/zita-dpl1/zita-dpl1.SlackBuild
+++ b/audio/zita-dpl1/zita-dpl1.SlackBuild
@@ -1,17 +1,23 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for zita-dpl1
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230106 bkw: BUILD=3, fix bad doc ownership, fix doinst.sh.
+# 20211205 bkw: BUILD=2, new-style icons.
+# 20191202 bkw: updated for v0.3.3
# 20170122 bkw: updated for v0.1.0
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=zita-dpl1
-VERSION=${VERSION:-0.1.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.3.3}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -21,7 +27,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -49,11 +59,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
sed -i \
@@ -61,12 +68,22 @@ if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
-e "s,-O2 -ffast-math,$SLKCFLAGS,"
fi
+sed -i 's,pkgconf,pkg-config,' source/Makefile
+
make -C source PREFIX=/usr
make -C source install PREFIX=/usr DESTDIR=$PKG
strip $PKG/usr/bin/$PRGNAM
+
+for px in 16 32 48 64 128; do
+ size=${px}x${px}
+ dir=$PKG/usr/share/icons/hicolor/$size/apps
+ mkdir -p $dir
+ convert -resize $size $CWD/$PRGNAM.png $dir/$PRGNAM.png
+done
+
mkdir -p $PKG/usr/share/pixmaps
-cat share/redzita.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
mkdir -p $PKG/usr/share/applications
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
@@ -75,8 +92,7 @@ mkdir -p $PKG/usr/man/man1
gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING LICENSE README doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -92,4 +108,4 @@ if [ "${SETCAP:-yes}" = "yes" ]; then
fi
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE