summaryrefslogtreecommitdiffstats
path: root/desktop/dmenu2
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/dmenu2')
-rw-r--r--desktop/dmenu2/README12
-rw-r--r--desktop/dmenu2/dmenu2-0.2-config-fix.diff30
-rw-r--r--desktop/dmenu2/dmenu2.SlackBuild99
-rw-r--r--desktop/dmenu2/dmenu2.info10
-rw-r--r--desktop/dmenu2/slack-desc19
5 files changed, 0 insertions, 170 deletions
diff --git a/desktop/dmenu2/README b/desktop/dmenu2/README
deleted file mode 100644
index 30bf059666..0000000000
--- a/desktop/dmenu2/README
+++ /dev/null
@@ -1,12 +0,0 @@
-dmenu2 (dynamic menu extended)
-
-dmenu2 is a fork of the original dmenu - an efficient dynamic menu for
-X patched with XFT, quiet, x & y, token, fuzzy matching, follow focus,
-tab nav, filter.
-
-Added option to set screen on which dmenu appears, as well as opacity,
-window class and window name. Also allows to dim screen with selected
-color and opacity while dmenu2 is running. Added underline color and
-height. (options -uc and -uh)
-
-NOTE: This package conflicts with the original dmenu package.
diff --git a/desktop/dmenu2/dmenu2-0.2-config-fix.diff b/desktop/dmenu2/dmenu2-0.2-config-fix.diff
deleted file mode 100644
index dd4316a847..0000000000
--- a/desktop/dmenu2/dmenu2-0.2-config-fix.diff
+++ /dev/null
@@ -1,30 +0,0 @@
---- config.mk 2014-09-13 18:36:13.478755045 +0300
-+++ a/config.mk 2014-09-13 18:36:18.552755303 +0300
-@@ -1,9 +1,10 @@
- # dmenu2 version
--VERSION = 0.1
-+VERSION = 0.2
-
- # paths
- PREFIX = /usr/local
- MANPREFIX = ${PREFIX}/share/man
-+LIBDIR = /usr/local/lib
-
- X11INC = /usr/X11R6/include
- X11LIB = /usr/X11R6/lib
-@@ -18,12 +19,13 @@
-
- # includes and libs
- INCS = -I${X11INC} ${XFTINC}
--LIBS = -L${X11LIB} -lX11 ${XINERAMALIBS} ${XFTLIBS}
-+LIBS = -L${LIBDIR} -L${X11LIB} -lX11 ${XINERAMALIBS} ${XFTLIBS}
-
- # flags
-+OPTS ?= 0s
- CPPFLAGS = -D_BSD_SOURCE -D_POSIX_C_SOURCE=2 -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
- #CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
--CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
-+CFLAGS = -std=c99 -pedantic -Wall ${OPTS} ${INCS} ${CPPFLAGS}
- LDFLAGS = -s ${LIBS}
-
- # compiler and linker
diff --git a/desktop/dmenu2/dmenu2.SlackBuild b/desktop/dmenu2/dmenu2.SlackBuild
deleted file mode 100644
index 4f1de8103b..0000000000
--- a/desktop/dmenu2/dmenu2.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/sh
-
-# Copyright (c) 2014, Simon Bolokanov, Bulgaria <sbolokanov@abv.bg>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Симон Болоканов <sbolokanov@abv.bg>
-# dmenu2 v0.2 - init script - 14.09.2014
-
-PRGNAM=dmenu2
-VERSION=${VERSION:-0.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# config setup
-patch -p1 < $CWD/dmenu2-0.2-config-fix.diff
-
-make clean install \
- OPTS="$SLKCFLAGS" \
- PREFIX=/usr \
- LIBDIR=/usr/lib${LIBDIRSUFFIX} \
- MANPREFIX=/usr/man \
- X11INC=/usr/include \
- X11LIB=/usr/lib${LIBDIRSUFFIX}/X11 \
- DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/dmenu2/dmenu2.info b/desktop/dmenu2/dmenu2.info
deleted file mode 100644
index 243f34cbe6..0000000000
--- a/desktop/dmenu2/dmenu2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="dmenu2"
-VERSION="0.2"
-HOMEPAGE="https://bitbucket.org/melek/dmenu2"
-DOWNLOAD="https://bitbucket.org/melek/dmenu2/downloads/dmenu2-0.2.tar.gz"
-MD5SUM="bc694c8b9fa3b8f6e7be8046d46e5bc5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Симон Болоканов"
-EMAIL="sbolokanov@abv.bg"
diff --git a/desktop/dmenu2/slack-desc b/desktop/dmenu2/slack-desc
deleted file mode 100644
index aedbfafd4d..0000000000
--- a/desktop/dmenu2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-dmenu2: dmenu2 (dynamic menu extended)
-dmenu2:
-dmenu2: dmenu2 is a fork of original dmenu - an efficient dynamic menu
-dmenu2: for X, patched with XFT, quiet, x & y, token, fuzzy matching, follow
-dmenu2: focus, tab nav, filter. Added option to set screen on which dmenu
-dmenu2: appears, as well as opacity, window class and window name.
-dmenu2: Also allows to dim screen with selected color and opacity while
-dmenu2: dmenu2 is running. Added underline color and height.
-dmenu2:
-dmenu2: Homepage: https://bitbucket.org/melek/dmenu2
-dmenu2: