summaryrefslogtreecommitdiffstats
path: root/desktop/ion/ion.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/ion/ion.SlackBuild')
-rw-r--r--desktop/ion/ion.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/desktop/ion/ion.SlackBuild b/desktop/ion/ion.SlackBuild
index dd4deb525b..a9b87316f9 100644
--- a/desktop/ion/ion.SlackBuild
+++ b/desktop/ion/ion.SlackBuild
@@ -49,7 +49,11 @@ rm -rf $PRGNAM-$SRC_VERSION
tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
cd $PRGNAM-$SRC_VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch system.mk after filtering it through sed to replace a few path issues,
# x86_64-specific things, and add optimization flags