summaryrefslogtreecommitdiffstats
path: root/desktop/kde-gtk-config
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/kde-gtk-config')
-rw-r--r--desktop/kde-gtk-config/README9
-rw-r--r--desktop/kde-gtk-config/doinst.sh6
-rw-r--r--desktop/kde-gtk-config/gtk3proxies.diff11
-rw-r--r--desktop/kde-gtk-config/gtkproxies.diff11
-rw-r--r--desktop/kde-gtk-config/kde-gtk-config.SlackBuild104
-rw-r--r--desktop/kde-gtk-config/kde-gtk-config.info10
-rw-r--r--desktop/kde-gtk-config/slack-desc19
7 files changed, 0 insertions, 170 deletions
diff --git a/desktop/kde-gtk-config/README b/desktop/kde-gtk-config/README
deleted file mode 100644
index 3ec12f0e2d..0000000000
--- a/desktop/kde-gtk-config/README
+++ /dev/null
@@ -1,9 +0,0 @@
-GTK2 and GTK3 Configurator for KDE.
-
-Configuration dialog to adapt GTK applications appearance to
-your taste under KDE. Among its many features, it lets you:
-- Choose which theme is used for GTK2 and GTK3 applications.
-- Tweak some GTK applications behaviour.
-- Select what icon theme to use in GTK applications.
-- Select GTK applications default fonts.
-- Easily browse and install new GTK2 and GTK3 themes.
diff --git a/desktop/kde-gtk-config/doinst.sh b/desktop/kde-gtk-config/doinst.sh
deleted file mode 100644
index 19400050fd..0000000000
--- a/desktop/kde-gtk-config/doinst.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
diff --git a/desktop/kde-gtk-config/gtk3proxies.diff b/desktop/kde-gtk-config/gtk3proxies.diff
deleted file mode 100644
index 8d0ef483fc..0000000000
--- a/desktop/kde-gtk-config/gtk3proxies.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/gtk3proxies/CMakeLists.txt 2017-03-16 20:19:44.291236607 -0400
-+++ b/gtk3proxies/CMakeLists.txt 2017-03-16 20:19:37.305236276 -0400
-@@ -2,7 +2,7 @@
-
- include_directories(${GTK3_INCLUDE_DIRS})
-
--add_definitions(-DDATA_DIR="\\\"${DATA_INSTALL_DIR}/kcm-gtk-module/\\\"")
-+add_definitions(-DDATA_DIR=\"${DATA_INSTALL_DIR}/kcm-gtk-module\")
-
- add_executable(gtk3_preview preview3.c)
- target_link_libraries(gtk3_preview ${GTK3_LIBRARY} ${GOBJECT2_LIBRARY} ${GLIB2_LIBRARY})
diff --git a/desktop/kde-gtk-config/gtkproxies.diff b/desktop/kde-gtk-config/gtkproxies.diff
deleted file mode 100644
index 45eac7ced7..0000000000
--- a/desktop/kde-gtk-config/gtkproxies.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/gtkproxies/CMakeLists.txt 2017-03-15 19:19:53.000000000 -0400
-+++ b/gtkproxies/CMakeLists.txt 2017-03-16 20:21:14.239240865 -0400
-@@ -6,7 +6,7 @@
- target_link_libraries(reload_gtk_apps ${GTK2_LIBRARIES})
- install(TARGETS reload_gtk_apps RUNTIME DESTINATION "${KDE4_LIBEXEC_INSTALL_DIR}")
-
--add_definitions(-DDATA_DIR="\\\"${DATA_INSTALL_DIR}/kcm-gtk-module/\\\"")
-+add_definitions(-DDATA_DIR=\"${DATA_INSTALL_DIR}/kcm-gtk-module\")
-
- add_executable(gtk_preview preview.c)
- target_link_libraries(gtk_preview ${GTK2_LIBRARIES} ${GTK2_GIOMM_LIBRARY})
diff --git a/desktop/kde-gtk-config/kde-gtk-config.SlackBuild b/desktop/kde-gtk-config/kde-gtk-config.SlackBuild
deleted file mode 100644
index 46747081c7..0000000000
--- a/desktop/kde-gtk-config/kde-gtk-config.SlackBuild
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for kde-gtk-config
-
-# Copyright 2017 Daniel Prosser | Lexington Park, MD
-# All rights reserved.
-#
-# Originally by Luis Henrique <lmello.009@gmail.com>
-# and Ryan P.C. McQuen <ryanpcmcquen@member.fsf.org>
-
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version, with the following exception:
-# the text of the GPL license may be omitted.
-
-# This program is distributed in the hope that it will be useful, but
-# without any warranty; without even the implied warranty of
-# merchantability or fitness for a particular purpose. Compiling,
-# interpreting, executing or merely reading the text of the program
-# may result in lapses of consciousness and/or very being, up to and
-# including the end of all existence and the Universe as we know it.
-# See the GNU General Public License for more details.
-
-# You may have received a copy of the GNU General Public License along
-# with this program (most likely, a file named COPYING). If not, see
-# <http://www.gnu.org/licenses/>.
-
-PRGNAM=kde-gtk-config
-VERSION=${VERSION:-2.2_git}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Patch some errors in cmake files to fix gtk_preview and gtk3_preview
-patch -p1 < $CWD/gtkproxies.diff
-patch -p1 < $CWD/gtk3proxies.diff
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/kde-gtk-config/kde-gtk-config.info b/desktop/kde-gtk-config/kde-gtk-config.info
deleted file mode 100644
index 6e59a1bbc0..0000000000
--- a/desktop/kde-gtk-config/kde-gtk-config.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="kde-gtk-config"
-VERSION="2.2_git"
-HOMEPAGE="https://projects.kde.org/kde-gtk-config"
-DOWNLOAD="https://sourceforge.net/projects/slackbuildsdirectlinks/files/kde-gtk-config/kde-gtk-config-2.2_git.tar.gz"
-MD5SUM="cabcba1af684f092c5e1cebb86be7c58"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Daniel Prosser"
-EMAIL="dpross1100@msn.com"
diff --git a/desktop/kde-gtk-config/slack-desc b/desktop/kde-gtk-config/slack-desc
deleted file mode 100644
index 002197d8b8..0000000000
--- a/desktop/kde-gtk-config/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-kde-gtk-config: kde-gtk-config (GTK2 and GTK3 Configurator for KDE)
-kde-gtk-config:
-kde-gtk-config: Configuration dialog to adapt GTK applications appearance to
-kde-gtk-config: your taste under KDE. Among its many features, it lets you:
-kde-gtk-config: - Choose which theme is used for GTK2 and GTK3 applications.
-kde-gtk-config: - Tweak some GTK applications behaviour.
-kde-gtk-config: - Select what icon theme to use in GTK applications.
-kde-gtk-config: - Select GTK applications default fonts.
-kde-gtk-config: - Easily browse and install new GTK2 and GTK3 themes.
-kde-gtk-config:
-kde-gtk-config: homepage: https://projects.kde.org/kde-gtk-config