summaryrefslogtreecommitdiffstats
path: root/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild')
-rw-r--r--desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild b/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
index 948814297b..2a1d93251f 100644
--- a/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
+++ b/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
@@ -1,8 +1,9 @@
#!/bin/sh
#
-# Slackware build script for numix-icon-theme-square.
+# Slackware build script for numix-icon-theme.
#
-# Copyright 2016-2017 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2015-2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM="numix-icon-theme-square"
-VERSION=${VERSION:-20170926}
+VERSION=${VERSION:-20191227}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -34,7 +35,7 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
CWD=$(pwd)
-SRCVER=${SRCVER:-1.0.1+11~201709261930~ubuntu17.10.1}
+SRCVER=${SRCVER:-19.12.27}
set -e
@@ -42,7 +43,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.xz
+tar xvf $CWD/${PRGNAM}-${SRCVER}.tar.gz
cd $PRGNAM-$SRCVER
chown -R root:root .
@@ -50,7 +51,7 @@ mkdir -p $PKG/usr/share/icons
cp -r Numix-Square Numix-Square-Light $PKG/usr/share/icons
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp debian/changelog LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -58,4 +59,11 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
+# 20200407 bkw: makepkg's symlink search and doinst.sh creation doesn't
+# scale well. This makes the build complete much faster, and create an
+# identical doinst.sh.
+find . -type l \
+ -printf '( cd %h ; rm -rf %f )\n( cd %h ; ln -sf %l %f )\n' -delete | \
+ sed 's,cd \./,cd ,' >> $PKG/install/doinst.sh
+
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}