summaryrefslogtreecommitdiffstats
path: root/desktop/py3status/py3status.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/py3status/py3status.SlackBuild')
-rw-r--r--desktop/py3status/py3status.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/desktop/py3status/py3status.SlackBuild b/desktop/py3status/py3status.SlackBuild
index 5aa2d91614..eb2b310e72 100644
--- a/desktop/py3status/py3status.SlackBuild
+++ b/desktop/py3status/py3status.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for py3status
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=py3status
-VERSION=${VERSION:-3.14}
+VERSION=${VERSION:-3.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true