summaryrefslogtreecommitdiffstats
path: root/development/MySQL-python
diff options
context:
space:
mode:
Diffstat (limited to 'development/MySQL-python')
-rw-r--r--development/MySQL-python/MySQL-python.SlackBuild27
-rw-r--r--development/MySQL-python/MySQL-python.info6
-rw-r--r--development/MySQL-python/patches/MySQL-python-1.2.4-include-my_config-first.patch33
-rw-r--r--development/MySQL-python/patches/no_distribute_download.patch12
4 files changed, 19 insertions, 59 deletions
diff --git a/development/MySQL-python/MySQL-python.SlackBuild b/development/MySQL-python/MySQL-python.SlackBuild
index c367b99dc9..0a8158e45c 100644
--- a/development/MySQL-python/MySQL-python.SlackBuild
+++ b/development/MySQL-python/MySQL-python.SlackBuild
@@ -1,14 +1,17 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for MySQL-python.
# Written by Jick Nan (jick.nan@gmail.com)
# Modified by the Slackbuilds.org project
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=MySQL-python
-VERSION=${VERSION:-1.2.4}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-1.2.5}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -18,7 +21,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -52,12 +62,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Avoid downloading distribute
-patch -p1 < $CWD/patches/no_distribute_download.patch
-# Include my_config.h first
-patch -p1 < $CWD/patches/MySQL-python-1.2.4-include-my_config-first.patch
-
-python setup.py install --root=$PKG
+CPPFLAGS="-I/usr/include/mysql/server" python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -72,4 +77,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/MySQL-python/MySQL-python.info b/development/MySQL-python/MySQL-python.info
index a64af09544..a96804f1af 100644
--- a/development/MySQL-python/MySQL-python.info
+++ b/development/MySQL-python/MySQL-python.info
@@ -1,8 +1,8 @@
PRGNAM="MySQL-python"
-VERSION="1.2.4"
+VERSION="1.2.5"
HOMEPAGE="https://pypi.python.org/pypi/MySQL-python"
-DOWNLOAD="https://pypi.python.org/packages/source/M/MySQL-python/MySQL-python-1.2.4.zip"
-MD5SUM="ddf2386daf10a97af115ffad2ed4a9a0"
+DOWNLOAD="https://pypi.python.org/packages/source/M/MySQL-python/MySQL-python-1.2.5.zip"
+MD5SUM="654f75b302db6ed8dc5a898c625e030c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/development/MySQL-python/patches/MySQL-python-1.2.4-include-my_config-first.patch b/development/MySQL-python/patches/MySQL-python-1.2.4-include-my_config-first.patch
deleted file mode 100644
index 81d2041f47..0000000000
--- a/development/MySQL-python/patches/MySQL-python-1.2.4-include-my_config-first.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur MySQL-python-1.2.4.orig/_mysql.c MySQL-python-1.2.4/_mysql.c
---- MySQL-python-1.2.4.orig/_mysql.c 2013-01-01 17:18:48.000000000 +0100
-+++ MySQL-python-1.2.4/_mysql.c 2014-11-07 20:25:20.483927425 +0100
-@@ -26,6 +26,14 @@
- PERFORMANCE OF THIS SOFTWARE.
- */
-
-+#if defined(MS_WINDOWS)
-+#include <config-win.h>
-+#else
-+#include "my_config.h"
-+#endif
-+#include "mysql.h"
-+#include "mysqld_error.h"
-+#include "errmsg.h"
- #include "Python.h"
- #if PY_MAJOR_VERSION >= 3
- #define IS_PY3K
-@@ -38,14 +46,6 @@
- #endif
- #include "pymemcompat.h"
- #include "structmember.h"
--#if defined(MS_WINDOWS)
--#include <config-win.h>
--#else
--#include "my_config.h"
--#endif
--#include "mysql.h"
--#include "mysqld_error.h"
--#include "errmsg.h"
-
- #if PY_VERSION_HEX < 0x02020000
- # define MyTuple_Resize(t,n,d) _PyTuple_Resize(t, n, d)
diff --git a/development/MySQL-python/patches/no_distribute_download.patch b/development/MySQL-python/patches/no_distribute_download.patch
deleted file mode 100644
index 2a94802373..0000000000
--- a/development/MySQL-python/patches/no_distribute_download.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur MySQL-python-1.2.4.orig/setup.py MySQL-python-1.2.4/setup.py
---- MySQL-python-1.2.4.orig/setup.py 2012-10-08 13:46:54.000000000 +0200
-+++ MySQL-python-1.2.4/setup.py 2013-12-06 20:34:36.214964072 +0100
-@@ -3,8 +3,6 @@
- import os
- import sys
-
--from distribute_setup import use_setuptools
--use_setuptools()
- from setuptools import setup, Extension
-
- if not hasattr(sys, "hexversion") or sys.hexversion < 0x02040000: