summaryrefslogtreecommitdiffstats
path: root/development/PyOpenGL/PyOpenGL.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/PyOpenGL/PyOpenGL.SlackBuild')
-rw-r--r--development/PyOpenGL/PyOpenGL.SlackBuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/development/PyOpenGL/PyOpenGL.SlackBuild b/development/PyOpenGL/PyOpenGL.SlackBuild
index 88f4c88fa5..b44e39bf77 100644
--- a/development/PyOpenGL/PyOpenGL.SlackBuild
+++ b/development/PyOpenGL/PyOpenGL.SlackBuild
@@ -7,19 +7,14 @@
## so that I don't recieve emails about a script I
## did not write. Thanks.
-# Modified slightly by the SlackBuilds.org project
-
-if [ "$(id -u)" != "0" ]; then
- echo "This script must be run as root!"
- exit
-fi
+# Modified by the SlackBuilds.org project
NAME=PyOpenGL
VERSION=3.0.0a5
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=${PKG:-$TMP/package-$NAME}
OUTPUT=${OUTPUT:-/tmp}
@@ -36,8 +31,10 @@ chmod -R u+w,go+r-w,a-s .
python setup.py bdist || exit 1
tar -C $PKG -zxvf $TMP/$NAME-$VERSION/dist/$NAME-$VERSION.linux-i686.tar.gz
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
mkdir -p $PKG/usr/doc/$NAME-$VERSION
install -m 0644 PKG-INFO documentation/{development,using}.html \