summaryrefslogtreecommitdiffstats
path: root/development/acpica/acpica.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/acpica/acpica.SlackBuild')
-rw-r--r--development/acpica/acpica.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/development/acpica/acpica.SlackBuild b/development/acpica/acpica.SlackBuild
index 275785695a..b108b35972 100644
--- a/development/acpica/acpica.SlackBuild
+++ b/development/acpica/acpica.SlackBuild
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=acpica
-VERSION=20100304
+VERSION=20100702
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -68,6 +66,7 @@ chown -R root:root .
chmod -R u+w,go+r-w,a-s .
cd compiler
+ sed -i "s|/components||" Makefile
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make MAKEFLAGS="-j1"
@@ -75,6 +74,10 @@ cd compiler
make clean
cd -
+# fix wrong paths in Makefile
+sed -i "s|/../source||" tools/acpiexec/Makefile
+sed -i "s|/components||" tools/acpiexec/Makefile
+
for i in acpiexec acpisrc acpixtract; do
cd tools/$i
CFLAGS="$SLKCFLAGS" \