summaryrefslogtreecommitdiffstats
path: root/development/atasm/atasm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/atasm/atasm.SlackBuild')
-rw-r--r--development/atasm/atasm.SlackBuild59
1 files changed, 34 insertions, 25 deletions
diff --git a/development/atasm/atasm.SlackBuild b/development/atasm/atasm.SlackBuild
index c454694204..7923307007 100644
--- a/development/atasm/atasm.SlackBuild
+++ b/development/atasm/atasm.SlackBuild
@@ -1,15 +1,27 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for atasm
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240207 bkw:
+# - update for v1.23, which is a maintained fork from a new dev.
+
+# 20221230 bkw:
+# - update for v1.09.
+# - install binary with standard permissions (0755).
+# - mention atari.txt in man page.
+# - run test suite (add "test" to make targets).
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=atasm
-VERSION=${VERSION:-1.07d}
+VERSION=${VERSION:-1.23}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -19,60 +31,57 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
-SRCNAM="${PRGNAM}${VERSION/./}"
-ZIPFILE="$SRCNAM.zip"
-SRCDIR="$( echo "$SRCNAM" | sed 's,[a-z]$,,' )"
-
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCDIR
-unzip $CWD/$ZIPFILE
-cd $SRCDIR
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz \
+ --exclude='*.exe' --exclude='*.sln' --exclude="*.vcx*"
+cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
DOCDIR=/usr/doc/$PRGNAM-$VERSION
# fix reference to full documentation.
sed -i \
- -e "s,$PRGNAM\.txt,$PRGNAM.pdf," \
+ -e "s,$PRGNAM\.txt,& (or $PRGNAM.pdf in the same directory)," \
-e "s,%%DOCDIR%%,$DOCDIR," \
src/$PRGNAM.1.in
-sed -i "s,-O3.*,$SLKCFLAGS," src/Makefile
+sed -i \
+ -e "s,-O3.*,$SLKCFLAGS," \
+ -e 's,\(chmod \)711,\1755,' \
+ src/Makefile
mkdir -p $PKG/usr/bin $PKG/usr/man/man1 $PKG/usr/doc/$PRGNAM-$VERSION
# 'make install' chokes because this file's missing:
touch $PRGNAM.txt
# N.B. nonstandard use of DESTDIR and MANDIR here.
-make -C src all install \
+make -C src all test install \
DESTDIR=$PKG/usr/bin \
MANDIR=$PKG/usr/man/man1 \
DOCDIR=$PKG/$DOCDIR
@@ -81,11 +90,11 @@ strip $PKG/usr/bin/$PRGNAM
gzip $PKG/usr/man/man1/$PRGNAM.1
rm -f $PKG/$DOCDIR/$PRGNAM.txt
-cp -a LICENSE *.TXT docs/* examples $PKG/$DOCDIR
+cp -a README* LICENSE* *.TXT docs/* examples $PKG/$DOCDIR
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE