summaryrefslogtreecommitdiffstats
path: root/development/beautysh/beautysh.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/beautysh/beautysh.SlackBuild')
-rw-r--r--development/beautysh/beautysh.SlackBuild92
1 files changed, 46 insertions, 46 deletions
diff --git a/development/beautysh/beautysh.SlackBuild b/development/beautysh/beautysh.SlackBuild
index 4cc1353ade..065e036324 100644
--- a/development/beautysh/beautysh.SlackBuild
+++ b/development/beautysh/beautysh.SlackBuild
@@ -1,31 +1,25 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for beautysh
-# Copyright 2018-2020 Leonardo Citrolo, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Originally written by Leonardo Citrolo, Italy
+# Now maintained by B. Watson (urchlay@slackware.uk).
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20230508 bkw:
+# - new maintainer.
+# - relicense as WTFPL with original author's permission.
+# - update for v6.2.1.
+# - expand README and slack-desc
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=beautysh
-VERSION=${VERSION:-6.0.1}
+VERSION=${VERSION:-6.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,24 +29,17 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
+LIB=lib
+[ "$ARCH" = "x86_64" ] && LIB=lib64
set -e
@@ -63,21 +50,34 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# For some reason, this requires "poetry", but our package is called
+# poetry-core according to python. *Many* thanks to fourtysixandtwo
+# for pointing this out. Also, there are a couple of bogus
+# not-really-required requirements listed, which prevent the --help
+# and --version options from showing the version number (and make 'pip
+# check' complain).
+sed -i -e '/^requires =/s,"poetry","poetry-core",' \
+ -e '/^types-\(colorama\|setuptools\)/d' \
+ pyproject.toml
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
-python3 setup.py install --root=$PKG
+# Redundant copy of this file (there's another in the right dir).
+rm -f $PKG/usr/lib*/python*/site-packages/LICENSE
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+PYVER=$(pkg-config --modversion python3)
+ln -s ../../$LIB/python$PYVER/site-packages/$PRGNAM-$VERSION.dist-info/LICENSE $PKGDOC
+cp -a README.* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE