summaryrefslogtreecommitdiffstats
path: root/development/cppunit
diff options
context:
space:
mode:
Diffstat (limited to 'development/cppunit')
-rw-r--r--development/cppunit/cppunit.SlackBuild63
-rw-r--r--development/cppunit/cppunit.info12
-rw-r--r--development/cppunit/slack-desc4
3 files changed, 46 insertions, 33 deletions
diff --git a/development/cppunit/cppunit.SlackBuild b/development/cppunit/cppunit.SlackBuild
index 16dc814492..073cc84cd3 100644
--- a/development/cppunit/cppunit.SlackBuild
+++ b/development/cppunit/cppunit.SlackBuild
@@ -1,19 +1,37 @@
#!/bin/sh
-# Slackware build script for cppunit
+# Slackware build script for CppUnit
-# Written by Luis Henrique <lmello.009@gmail.com>
+# Copyright 2014 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cppunit
-VERSION=${VERSION:-1.12.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.13.2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
+ case "$(uname -m)" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
+ *) ARCH=$(uname -m) ;;
esac
fi
@@ -22,6 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+DOCS="AUTHORS BUGS COPYING ChangeLog CodingGuideLines.txt INSTALL* NEWS README THANKS TODO"
+
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -36,7 +56,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -45,11 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+chmod -R u+w,go-w,a+rX-st .
+
+# Make it respect --htmldir.
+sed -i '/^htmldir/d' doc/Makefile.am
+autoreconf -vif
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -61,24 +81,17 @@ CXXFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--htmldir=/usr/doc/$PRGNAM-$VERSION/html \
- --enable-static=no \
- --enable-shared=yes \
- --build=$ARCH-slackware-linux
+ --build=$ARCH-slackware-linux \
+ --disable-static \
+ --disable-dependency-tracking
make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+make install-strip DESTDIR=$PKG
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+find $PKG/usr/man -type f -exec gzip -9 {} +
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS BUGS COPYING ChangeLog CodingGuideLines.txt INSTALL \
- INSTALL-WIN32.txt INSTALL-unix NEWS README THANKS TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/cppunit/cppunit.info b/development/cppunit/cppunit.info
index d471fe1bce..4a4032f15f 100644
--- a/development/cppunit/cppunit.info
+++ b/development/cppunit/cppunit.info
@@ -1,10 +1,10 @@
PRGNAM="cppunit"
-VERSION="1.12.1"
-HOMEPAGE="http://cppunit.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/cppunit/cppunit-1.12.1.tar.gz"
-MD5SUM="bd30e9cf5523cdfc019b94f5e1d7fd19"
+VERSION="1.13.2"
+HOMEPAGE="http://freedesktop.org/wiki/Software/cppunit/"
+DOWNLOAD="http://dev-www.libreoffice.org/src/cppunit-1.13.2.tar.gz"
+MD5SUM="d1c6bdd5a76c66d2c38331e2d287bc01"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Luís Henrique"
-EMAIL="lmello.009@gmail.com"
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
diff --git a/development/cppunit/slack-desc b/development/cppunit/slack-desc
index d9cfc2c51e..cbf4be5dc9 100644
--- a/development/cppunit/slack-desc
+++ b/development/cppunit/slack-desc
@@ -6,12 +6,12 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-cppunit: cppunit (C++ unit testing framework)
+cppunit: CppUnit (C++ unit testing framework)
cppunit:
cppunit: CppUnit is a C++ unit testing framework.
cppunit: It started its life as a port of JUnit to C++ by Michael Feathers.
cppunit:
-cppunit: Homepage: http://cppunit.sourceforge.net
+cppunit:
cppunit:
cppunit:
cppunit: