summaryrefslogtreecommitdiffstats
path: root/development/device-tree-compiler/fix-python-destdir-usage.diff
diff options
context:
space:
mode:
Diffstat (limited to 'development/device-tree-compiler/fix-python-destdir-usage.diff')
-rw-r--r--development/device-tree-compiler/fix-python-destdir-usage.diff12
1 files changed, 12 insertions, 0 deletions
diff --git a/development/device-tree-compiler/fix-python-destdir-usage.diff b/development/device-tree-compiler/fix-python-destdir-usage.diff
new file mode 100644
index 0000000000..49b3c14d5b
--- /dev/null
+++ b/development/device-tree-compiler/fix-python-destdir-usage.diff
@@ -0,0 +1,12 @@
+diff -Nur device-tree-compiler-1.6.0.orig/pylibfdt/Makefile.pylibfdt device-tree-compiler-1.6.0/pylibfdt/Makefile.pylibfdt
+--- device-tree-compiler-1.6.0.orig/pylibfdt/Makefile.pylibfdt 2020-03-04 00:14:58.000000000 -0600
++++ device-tree-compiler-1.6.0/pylibfdt/Makefile.pylibfdt 2021-11-06 12:38:30.133022247 -0500
+@@ -22,7 +22,7 @@
+
+ install_pylibfdt: $(PYMODULE)
+ @$(VECHO) INSTALL-PYLIB
+- $(PYTHON) $(SETUP) $(SETUPFLAGS) install --prefix=$(PREFIX)
++ $(PYTHON) $(SETUP) $(SETUPFLAGS) install --prefix=$(PREFIX) --root=$(DESTDIR)
+
+ pylibfdt_clean:
+ @$(VECHO) CLEAN "(pylibfdt)"