summaryrefslogtreecommitdiffstats
path: root/development/easygui/easygui.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/easygui/easygui.SlackBuild')
-rw-r--r--development/easygui/easygui.SlackBuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/development/easygui/easygui.SlackBuild b/development/easygui/easygui.SlackBuild
index 81a03d9a70..a38ba416aa 100644
--- a/development/easygui/easygui.SlackBuild
+++ b/development/easygui/easygui.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for easygui
-# Copyright 2007-2009 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2007-2010 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=easygui
-VERSION=${VERSION:-0.93}
+VERSION=${VERSION:-0.95}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -56,11 +54,11 @@ else
fi
# directory for python packages
-PYTHONDIR="/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages"
+PYTHONDIR=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
SAMPLEFILE="python_and_check_logo.gif"
DOCFILES="*.txt *.html"
-set -e # Exit on most errors
+set -e # Exit on most errors
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -70,11 +68,15 @@ mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}_${SRC_VERSION}.tar.gz
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
# install .py source file and sample file
+python ./setup.py build install --root=$PKG
mkdir -p $PKG/$PYTHONDIR
-install -m 0644 $PRGNAM.py $PKG/$PYTHONDIR
cp -a $SAMPLEFILE $PKG/$PYTHONDIR
# Copy documentation files