summaryrefslogtreecommitdiffstats
path: root/development/gforth/gforth.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/gforth/gforth.SlackBuild')
-rw-r--r--development/gforth/gforth.SlackBuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/development/gforth/gforth.SlackBuild b/development/gforth/gforth.SlackBuild
index ff7d92dc33..ff5c4cdaba 100644
--- a/development/gforth/gforth.SlackBuild
+++ b/development/gforth/gforth.SlackBuild
@@ -2,10 +2,10 @@
# Slackware build script for gforth
-# Written by Zbigniew Baniewski, <Zbigniew.Baniewski@gmail.com>
+# Written by Zbigniew Baniewski, <Zbigniew [dot] Baniewski [at] gmail [dot] com>
PRGNAM=gforth
-VERSION=0.7.2
+VERSION=${VERSION:-0.7.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -49,10 +49,10 @@ patch -p0 < $CWD/01-Makefile.in.patch
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix old-style flag
sed -i "s/-m486/-mtune=i486/g" configure.in
@@ -69,7 +69,7 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
@@ -79,9 +79,7 @@ rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*.info*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- doc/gforth.ps AUTHORS BUGS COPYING* ChangeLog NEWS* README* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/gforth.ps AUTHORS BUGS COPYING* ChangeLog NEWS* README* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install