summaryrefslogtreecommitdiffstats
path: root/development/gr-osmosdr/gr-osmosdr.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/gr-osmosdr/gr-osmosdr.SlackBuild')
-rw-r--r--development/gr-osmosdr/gr-osmosdr.SlackBuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/development/gr-osmosdr/gr-osmosdr.SlackBuild b/development/gr-osmosdr/gr-osmosdr.SlackBuild
index 7831a9de81..6d4d116fd9 100644
--- a/development/gr-osmosdr/gr-osmosdr.SlackBuild
+++ b/development/gr-osmosdr/gr-osmosdr.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for gr-osmosdr
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=gr-osmosdr
-VERSION=${VERSION:-20170612}
+VERSION=${VERSION:-20210128_a100eb0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -70,9 +80,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i "s|gr_osmosdr_libs}|gr_osmosdr_libs} -lboost_chrono|" lib/CMakeLists.txt
-patch -p1 < $CWD/boost-1.73.patch
-
mkdir -p build
cd build
cmake \
@@ -97,4 +104,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE