summaryrefslogtreecommitdiffstats
path: root/development/hackrf/hackrf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/hackrf/hackrf.SlackBuild')
-rw-r--r--development/hackrf/hackrf.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/development/hackrf/hackrf.SlackBuild b/development/hackrf/hackrf.SlackBuild
index d28b03c6a0..60c8d99420 100644
--- a/development/hackrf/hackrf.SlackBuild
+++ b/development/hackrf/hackrf.SlackBuild
@@ -67,7 +67,7 @@ fi
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION/host
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -75,6 +75,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+cd host
sed -i "s|lib/pkgconfig|lib${LIBDIRSUFFIX}/pkgconfig|" libhackrf/CMakeLists.txt
mkdir -p build
cd build