summaryrefslogtreecommitdiffstats
path: root/development/jupyter-nbformat/jupyter-nbformat.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-nbformat/jupyter-nbformat.SlackBuild')
-rw-r--r--development/jupyter-nbformat/jupyter-nbformat.SlackBuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/development/jupyter-nbformat/jupyter-nbformat.SlackBuild b/development/jupyter-nbformat/jupyter-nbformat.SlackBuild
index 313a5136ad..b903ed33ed 100644
--- a/development/jupyter-nbformat/jupyter-nbformat.SlackBuild
+++ b/development/jupyter-nbformat/jupyter-nbformat.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for jupyter-nbformat
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-nbformat
-VERSION=${VERSION:-5.1.3}
+VERSION=${VERSION:-5.9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,15 +79,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING.md README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install