summaryrefslogtreecommitdiffstats
path: root/development/jupyter-notebook/jupyter-notebook.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-notebook/jupyter-notebook.SlackBuild')
-rw-r--r--development/jupyter-notebook/jupyter-notebook.SlackBuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/development/jupyter-notebook/jupyter-notebook.SlackBuild b/development/jupyter-notebook/jupyter-notebook.SlackBuild
index f5dcb7ac1c..efd511a7c4 100644
--- a/development/jupyter-notebook/jupyter-notebook.SlackBuild
+++ b/development/jupyter-notebook/jupyter-notebook.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for jupyter-notebook
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-notebook
-VERSION=${VERSION:-6.4.11}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-6.5.4}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -82,19 +79,22 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix traitlets warning and error:
+# https://github.com/jupyter/notebook/pull/7051
+patch -p1 < $CWD/fix-traitlets-error.patch
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGELOG.md CONTRIBUTING.rst LICENSE PKG-INFO README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.rst LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE