summaryrefslogtreecommitdiffstats
path: root/development/jupyter_console/jupyter_console.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter_console/jupyter_console.SlackBuild')
-rw-r--r--development/jupyter_console/jupyter_console.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/development/jupyter_console/jupyter_console.SlackBuild b/development/jupyter_console/jupyter_console.SlackBuild
index e902c62077..ca5a253299 100644
--- a/development/jupyter_console/jupyter_console.SlackBuild
+++ b/development/jupyter_console/jupyter_console.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyter_console
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=jupyter_console
-VERSION=${VERSION:-5.2.0}
+VERSION=${VERSION:-6.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true