summaryrefslogtreecommitdiffstats
path: root/development/jupyter_core/jupyter_core.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter_core/jupyter_core.SlackBuild')
-rw-r--r--development/jupyter_core/jupyter_core.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/development/jupyter_core/jupyter_core.SlackBuild b/development/jupyter_core/jupyter_core.SlackBuild
index de50b045fe..551c5293ad 100644
--- a/development/jupyter_core/jupyter_core.SlackBuild
+++ b/development/jupyter_core/jupyter_core.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyter_core
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=jupyter_core
-VERSION=${VERSION:-4.4.0}
+VERSION=${VERSION:-4.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true