summaryrefslogtreecommitdiffstats
path: root/development/jupyter_core/jupyter_core.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter_core/jupyter_core.SlackBuild')
-rw-r--r--development/jupyter_core/jupyter_core.SlackBuild52
1 files changed, 5 insertions, 47 deletions
diff --git a/development/jupyter_core/jupyter_core.SlackBuild b/development/jupyter_core/jupyter_core.SlackBuild
index 19ff1ec940..ab9293471f 100644
--- a/development/jupyter_core/jupyter_core.SlackBuild
+++ b/development/jupyter_core/jupyter_core.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for jupyter_core
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter_core
-VERSION=${VERSION:-4.11.1}
+VERSION=${VERSION:-5.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -80,39 +63,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from setuptools import setup
-import os
-here = os.path.abspath(os.path.dirname(__file__))
-pjoin = os.path.join
-packages = []
-for d, _, _ in os.walk(pjoin(here, 'jupyter_core')):
- packages.append(d[len(here)+1:].replace(os.path.sep, '.'))
-setup(name='${PRGNAM}',
- version='${VERSION}',
- packages=packages,
- py_modules=['jupyter'],
- entry_points={
- 'console_scripts': [
- 'jupyter = jupyter_core.command:main',
- 'jupyter-migrate = jupyter_core.migrate:main',
- 'jupyter-troubleshoot = jupyter_troubleshoot.migrate:main',
- ],
- },
- package_data={'': ['*']},
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CONTRIBUTING.md COPYING.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install