summaryrefslogtreecommitdiffstats
path: root/development/kakoune/kakoune.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/kakoune/kakoune.SlackBuild')
-rw-r--r--development/kakoune/kakoune.SlackBuild95
1 files changed, 49 insertions, 46 deletions
diff --git a/development/kakoune/kakoune.SlackBuild b/development/kakoune/kakoune.SlackBuild
index 6edc590cfb..fda7cbd932 100644
--- a/development/kakoune/kakoune.SlackBuild
+++ b/development/kakoune/kakoune.SlackBuild
@@ -1,31 +1,31 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for kakoune
-# Copyright 2018-2019 Leonardo Citrolo, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Oritinally written by Leonardo Citrolo.
+# Now maintained by B. Watson (urchlay@slackware.uk).
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20231108 bkw: update for v2023.08.05.
+# 20230509 bkw:
+# - new maintainer.
+# - update for v2022.10.31.
+# - relicense as WTFPL with permission from original author.
+# - override -O3 with $SLKCFLAGS.
+
+# Note: I (B. Watson) took over this build to keep it from
+# disappearing from the repo, but if you actually use and enjoy
+# kakoune, please take the build from me (ask via email). I can't
+# stand to actually use kakoune (tried it, utterly hate it, sorry).
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=kakoune
-VERSION=${VERSION:-2019.01.20}
+VERSION=${VERSION:-2023.08.05}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,23 +35,23 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
@@ -63,31 +63,34 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-CXXFLAGS="$SLKCFLAGS" \
- make -C src PREFIX=/usr
-make -C src install DESTDIR=$PKG \
- PREFIX=/usr \
- docdir=$PKG/usr/doc/$PRGNAM-$VERSION \
- mandir=$PKG/usr/man/man1
+rm libexec/kak/kak # dangling symlink
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# N.B. slightly nonstandard use of DESTDIR: we have to include $PKG
+# in docdir and mandir, below.
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+sed -i "s,-O3,$SLKCFLAGS," src/Makefile
+make -C src PREFIX=/usr
+strip src/kak
+make -C src \
+ PREFIX=/usr \
+ docdir=$PKGDOC \
+ mandir=$PKG/usr/man/man1 \
+ DESTDIR=$PKG \
+ install
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+# Man page already gzipped, we stripped the binary above. Thought
+# about symlinking all the asciidoc from /usr/share/kak to our doc
+# dir, but it's intended to be read from within kak, with the :doc
+# command.
-cp -a CONTRIBUTING UNLICENSE VIMTOKAK \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cp -a CONTRIBUTING UNLICENSE VIMTOKAK $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE