summaryrefslogtreecommitdiffstats
path: root/development/lua52/lua.pc
diff options
context:
space:
mode:
Diffstat (limited to 'development/lua52/lua.pc')
-rw-r--r--development/lua52/lua.pc31
1 files changed, 31 insertions, 0 deletions
diff --git a/development/lua52/lua.pc b/development/lua52/lua.pc
new file mode 100644
index 0000000000..7d8a1abf40
--- /dev/null
+++ b/development/lua52/lua.pc
@@ -0,0 +1,31 @@
+# lua.pc -- pkg-config data for Lua
+
+# vars from install Makefile
+
+# grep '^V=' ../Makefile
+V= 5.2
+# grep '^R=' ../Makefile
+R= 5.2.0
+
+# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
+prefix= /usr
+INSTALL_BIN= ${prefix}/bin
+INSTALL_INC= ${prefix}/include
+INSTALL_LIB= ${prefix}/lib
+INSTALL_MAN= ${prefix}/man/man1
+INSTALL_LMOD= ${prefix}/share/lua/${V}
+INSTALL_CMOD= ${prefix}/lib/lua/${V}
+
+# canonical vars
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: Lua
+Description: An Extensible Extension Language
+Version: ${R}
+Requires:
+Libs: -L${libdir} -llua -lm
+Cflags: -I${includedir}
+
+# (end of lua.pc)