summaryrefslogtreecommitdiffstats
path: root/development/ocaml/ocaml.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/ocaml/ocaml.SlackBuild')
-rw-r--r--development/ocaml/ocaml.SlackBuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/development/ocaml/ocaml.SlackBuild b/development/ocaml/ocaml.SlackBuild
index 677774f1ac..d97021f342 100644
--- a/development/ocaml/ocaml.SlackBuild
+++ b/development/ocaml/ocaml.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ocaml
-# Copyright 2007-2009 Ferenc Deak <ferenc.deak@gmail.com>
+# Copyright 2007-2011 Ferenc Deak <ferenc.deak@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ocaml
-VERSION=3.11.1
+VERSION=3.12.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -67,14 +65,13 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-./configure \
+patch < $CWD/configure.patch
+
+CFLAGS="$SLKCFLAGS" ./configure \
--prefix /usr \
--libdir /usr/lib${LIBDIRSUFFIX}/ocaml \
--host $ARCH-slackware-linux
-sed -i -e "s/\\(BYTECCCOMPOPTS=.*\\)/\\1 ${SLKCFLAGS}/" config/Makefile
-sed -i -e "s/\\(NATIVECCCOMPOPTS=.*\\)/\\1 ${SLKCFLAGS}/" config/Makefile
-
make world.opt
make install \
PREFIX=$PKG/usr \
@@ -88,6 +85,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a Changes INSTALL LICENSE README README.win32 Upgrading VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/ocaml-3.12-refman.html > $PKG/usr/doc/$PRGNAM-$VERSION/ocaml-refman.html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install