summaryrefslogtreecommitdiffstats
path: root/development/psycopg2/psycopg2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/psycopg2/psycopg2.SlackBuild')
-rw-r--r--development/psycopg2/psycopg2.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/development/psycopg2/psycopg2.SlackBuild b/development/psycopg2/psycopg2.SlackBuild
index 9b30bcc5cd..c75fff9d34 100644
--- a/development/psycopg2/psycopg2.SlackBuild
+++ b/development/psycopg2/psycopg2.SlackBuild
@@ -24,16 +24,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psycopg2
-VERSION=${VERSION:-2.0.14}
+VERSION=${VERSION:-2.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -56,8 +54,8 @@ chmod -R u+w,go+r-w,a-s .
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG | xargs file | grep "shared object" | grep ELF | \
+ cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog LICENSE PKG-INFO README doc/*.txt \