summaryrefslogtreecommitdiffstats
path: root/development/psycopg2
diff options
context:
space:
mode:
Diffstat (limited to 'development/psycopg2')
-rw-r--r--development/psycopg2/psycopg2.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/development/psycopg2/psycopg2.SlackBuild b/development/psycopg2/psycopg2.SlackBuild
index 56814b8e14..e7acad4154 100644
--- a/development/psycopg2/psycopg2.SlackBuild
+++ b/development/psycopg2/psycopg2.SlackBuild
@@ -58,6 +58,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true