summaryrefslogtreecommitdiffstats
path: root/development/pysetuptools/pysetuptools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/pysetuptools/pysetuptools.SlackBuild')
-rw-r--r--development/pysetuptools/pysetuptools.SlackBuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/development/pysetuptools/pysetuptools.SlackBuild b/development/pysetuptools/pysetuptools.SlackBuild
index 14890bfb8c..37105795a2 100644
--- a/development/pysetuptools/pysetuptools.SlackBuild
+++ b/development/pysetuptools/pysetuptools.SlackBuild
@@ -9,9 +9,11 @@
# Mofified by the SlackBuilds.org project
+# Maintained by Audrius Kažukauskas <audrius@neutrino.lt>
+
PRGNAM=pysetuptools
SRC_NAME=setuptools
-VERSION=0.6c9
+VERSION=0.6c11
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -32,15 +34,12 @@ cd $SRC_NAME-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-python setup.py install --root=$PKG
+# Don't need this.
+rm -f setuptools/*.exe
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
+python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
install -m 0644 *.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -48,4 +47,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}