summaryrefslogtreecommitdiffstats
path: root/development/sdcc/sdcc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/sdcc/sdcc.SlackBuild')
-rw-r--r--development/sdcc/sdcc.SlackBuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/development/sdcc/sdcc.SlackBuild b/development/sdcc/sdcc.SlackBuild
index d525f39e14..9a9fdf5f1f 100644
--- a/development/sdcc/sdcc.SlackBuild
+++ b/development/sdcc/sdcc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sdcc
-# Copyright 2014-2018 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2014-2019 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sdcc
-VERSION=${VERSION:-3.8.0}
+VERSION=${VERSION:-3.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -76,9 +76,10 @@ chmod -x device/lib/isinf.c device/lib/isnan.c
# A few Makefiles install (copy) the source tree _after_ building, and
# accidentally install a bunch of build byproducts which they try to clean
# up afterwards. Delete some byproducts that they missed.
-for patch in $CWD/patches/* ; do
- patch -p1 < $patch
-done
+patch -p1 < $CWD/patches/source-tree.patch
+
+# Avoid creating empty man directories.
+sed -i '/(man1dir)/d' sim/ucsim/doc/Makefile.in
# Requires lyx, latex2html, possibly others. Untested.
if [ "${ENABLE_DOC:-no}" != 'no' ]; then