summaryrefslogtreecommitdiffstats
path: root/development/valgrind/valgrind-3.5.0-glibc-2.11.patch
diff options
context:
space:
mode:
Diffstat (limited to 'development/valgrind/valgrind-3.5.0-glibc-2.11.patch')
-rw-r--r--development/valgrind/valgrind-3.5.0-glibc-2.11.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/development/valgrind/valgrind-3.5.0-glibc-2.11.patch b/development/valgrind/valgrind-3.5.0-glibc-2.11.patch
new file mode 100644
index 0000000000..4866ee5326
--- /dev/null
+++ b/development/valgrind/valgrind-3.5.0-glibc-2.11.patch
@@ -0,0 +1,51 @@
+From valgrind SVN
+------------------------------------------------------------------------
+r10941 | bart | 2009-11-16 06:11:19 +1100 (Mon, 16 Nov 2009) | 2 lines
+
+Added support for glibc 2.11.
+
+------------------------------------------------------------------------
+Index: configure.in
+===================================================================
+--- configure.in (revision 10940)
++++ configure.in (revision 10941)
+@@ -656,6 +656,16 @@
+ ],
+ GLIBC_VERSION="2.10")
+
++AC_EGREP_CPP([GLIBC_211], [
++#include <features.h>
++#ifdef __GNU_LIBRARY__
++ #if (__GLIBC__ == 2 && __GLIBC_MINOR__ == 11)
++ GLIBC_211
++ #endif
++#endif
++],
++GLIBC_VERSION="2.11")
++
+ AC_EGREP_CPP([AIX5_LIBC], [
+ #include <standards.h>
+ #if defined(_AIXVERSION_510) || defined(_AIXVERSION_520) || defined(_AIXVERSION_530)
+@@ -742,6 +752,13 @@
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
+ ;;
++ 2.11)
++ AC_MSG_RESULT(2.11 family)
++ AC_DEFINE([GLIBC_2_11], 1, [Define to 1 if you're using glibc 2.11.x])
++ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
++ ;;
+ aix5)
+ AC_MSG_RESULT(AIX 5.1 or 5.2 or 5.3)
+ AC_DEFINE([AIX5_LIBC], 1, [Define to 1 if you're using AIX 5.1 or 5.2 or 5.3])
+@@ -755,7 +772,7 @@
+
+ *)
+ AC_MSG_RESULT(unsupported version)
+- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.10])
++ AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.11])
+ AC_MSG_ERROR([or AIX 5.1 or 5.2 or 5.3 GLIBC_VERSION])
+ AC_MSG_ERROR([or Darwin libc])
+ ;;