summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
Diffstat (limited to 'development')
-rw-r--r--development/bzr/bzr.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/development/bzr/bzr.SlackBuild b/development/bzr/bzr.SlackBuild
index e70687dd3e..cd32fcf2de 100644
--- a/development/bzr/bzr.SlackBuild
+++ b/development/bzr/bzr.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for bzr
-# Copyright 2006,2007,2008,2009,2010 Robby Workman Northport, AL, USA
+# Copyright 2006-2011 Robby Workman Northport, AL, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=bzr
VERSION=2.2.2
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -73,6 +73,9 @@ find . \
make docs 2>/dev/null || true
python setup.py install --root=$PKG
+# We don't need the apport junk
+rm -rf $PKG/usr/share $PKG/etc
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true