summaryrefslogtreecommitdiffstats
path: root/games/FlightGear
diff options
context:
space:
mode:
Diffstat (limited to 'games/FlightGear')
-rw-r--r--games/FlightGear/FlightGear-version.patch29
-rw-r--r--games/FlightGear/FlightGear.SlackBuild10
-rw-r--r--games/FlightGear/FlightGear.info6
-rw-r--r--games/FlightGear/README2
4 files changed, 6 insertions, 41 deletions
diff --git a/games/FlightGear/FlightGear-version.patch b/games/FlightGear/FlightGear-version.patch
deleted file mode 100644
index b3fef66c61..0000000000
--- a/games/FlightGear/FlightGear-version.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -Naur flightgear-2020.1.2/CMakeLists.txt flightgear-2020.1.2.new/CMakeLists.txt
---- flightgear-2020.1.2/CMakeLists.txt 2020-05-24 11:14:48.000000000 -0400
-+++ flightgear-2020.1.2.new/CMakeLists.txt 2020-06-01 09:51:41.076758051 -0400
-@@ -83,13 +83,13 @@
- set(CMAKE_MINSIZEREL_POSTFIX "" CACHE STRING "add a postfix, usually empty on windows")
-
- # read 'version' file into a variable (stripping any newlines or spaces)
--file(READ version versionFile)
-+file(READ flightgear-version versionFile)
- if (NOT versionFile)
- message(FATAL_ERROR "Unable to determine FlightGear version. Version file is missing.")
- endif()
- string(STRIP "${versionFile}" FLIGHTGEAR_VERSION)
- # add a dependency on the version file
--set_property(DIRECTORY APPEND PROPERTY CMAKE_CONFIGURE_DEPENDS version)
-+set_property(DIRECTORY APPEND PROPERTY CMAKE_CONFIGURE_DEPENDS flightgear-version)
-
- # FlightGear packaging (to build a source tarball)
- include( ConfigureCPack )
-diff -Naur flightgear-2020.1.2/flightgear-version flightgear-2020.1.2.new/flightgear-version
---- flightgear-2020.1.2/flightgear-version 1969-12-31 19:00:00.000000000 -0500
-+++ flightgear-2020.1.2.new/flightgear-version 2020-05-24 11:14:48.000000000 -0400
-@@ -0,0 +1 @@
-+2020.1.2
-diff -Naur flightgear-2020.1.2/version flightgear-2020.1.2.new/version
---- flightgear-2020.1.2/version 2020-05-24 11:14:48.000000000 -0400
-+++ flightgear-2020.1.2.new/version 1969-12-31 19:00:00.000000000 -0500
-@@ -1 +0,0 @@
--2020.1.2
diff --git a/games/FlightGear/FlightGear.SlackBuild b/games/FlightGear/FlightGear.SlackBuild
index 83b65b6ab8..fed48f1bff 100644
--- a/games/FlightGear/FlightGear.SlackBuild
+++ b/games/FlightGear/FlightGear.SlackBuild
@@ -26,7 +26,7 @@
PRGNAM=FlightGear
SRCNAM=flightgear
-VERSION=${VERSION:-2020.1.2}
+VERSION=${VERSION:-2020.3.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -79,11 +79,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# patch for the new boost (Thanks Gentoo)
-if [ "${CURRENT:-no}" = "yes" ]; then
- patch -p1 < $CWD/FlightGear-version.patch
-fi
-
mkdir -p build
cd build
cmake \
@@ -93,7 +88,8 @@ cd build
-DEVENT_INPUT="ON" \
-DFG_DATA_DIR=/usr/share/${PRGNAM} \
$OPT \
- -DCMAKE_BUILD_TYPE=Release ..
+ -DCMAKE_BUILD_TYPE=Release \
+ -DFG_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
diff --git a/games/FlightGear/FlightGear.info b/games/FlightGear/FlightGear.info
index 87ed0d7f2f..15c3db0072 100644
--- a/games/FlightGear/FlightGear.info
+++ b/games/FlightGear/FlightGear.info
@@ -1,8 +1,8 @@
PRGNAM="FlightGear"
-VERSION="2020.1.2"
+VERSION="2020.3.6"
HOMEPAGE="http://www.flightgear.org/"
-DOWNLOAD="https://downloads.sourceforge.net/flightgear/flightgear-2020.1.2.tar.bz2"
-MD5SUM="146bee62c1d28736815cba583fd0395a"
+DOWNLOAD="https://downloads.sourceforge.net/flightgear/flightgear-2020.3.6.tar.bz2"
+MD5SUM="ba2ff86313ff8e926a6653492bae1005"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="FlightGear-data SimGear"
diff --git a/games/FlightGear/README b/games/FlightGear/README
index 3b576ddb62..40164a5f29 100644
--- a/games/FlightGear/README
+++ b/games/FlightGear/README
@@ -6,7 +6,5 @@ To build the internal Qt launcher, you will require QT5 and then pass
QT5=yes to the script. Otherwise, you can install either fgo or ffgo
as a more basic launcher.
-To build on current (15.0 EXPERIMENTAL), pass CURRENT=yes to the script.
-
speex and flite are optional dependencies for voice communication
(autodetected at build time).