summaryrefslogtreecommitdiffstats
path: root/games/OpenRA
diff options
context:
space:
mode:
Diffstat (limited to 'games/OpenRA')
-rw-r--r--games/OpenRA/OpenRA.SlackBuild46
-rw-r--r--games/OpenRA/OpenRA.info16
-rw-r--r--games/OpenRA/fetch-thirdparty-deps.sh.new18
3 files changed, 38 insertions, 42 deletions
diff --git a/games/OpenRA/OpenRA.SlackBuild b/games/OpenRA/OpenRA.SlackBuild
index ca32d10a54..139b218864 100644
--- a/games/OpenRA/OpenRA.SlackBuild
+++ b/games/OpenRA/OpenRA.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for OpenRA
-# Copyright 2017 Vasily Sora USA
+# Copyright 2017,2022 Vasily Sora USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=OpenRA
-VERSION=${VERSION:-20190314}
+VERSION=${VERSION:-20210321}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,10 +38,21 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+HOME=$TMP/$PRGNAM-release-$VERSION-source
+DOTNET_CLI_TELEMETRY_OPTOUT=1
+export HOME DOTNET_CLI_TELEMETRY_OPTOUT
+
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
@@ -61,15 +75,15 @@ rm -rf $TMP/$PRGNAM-release-$VERSION-source
mkdir -p $TMP $PKG $OUTPUT $TMP/$PRGNAM-release-$VERSION-source
cd $TMP/$PRGNAM-release-$VERSION-source
tar xvf $CWD/$PRGNAM-release-$VERSION-source.tar.bz2
-cp $CWD/fetch-thirdparty-deps.sh.new thirdparty/fetch-thirdparty-deps.sh
-cp $CWD/download.tar.gz thirdparty
-mkdir thirdparty/download/
-cp $CWD/GeoLite2-Country.mmdb.gz thirdparty/download/
-rm thirdparty/fetch-geoip-db.sh
-touch thirdparty/fetch-geoip-db.sh
-echo "#!/bin/sh" >> thirdparty/fetch-geoip-db.sh
-echo 'echo "success"' >> thirdparty/fetch-geoip-db.sh
-chmod +x thirdparty/fetch-geoip-db.sh
+tar -xzvf $CWD/openra-deps.tar.gz
+cp $CWD/IP2LOCATION-LITE-DB1.IPV6.BIN.ZIP .
+rm fetch-geoip.sh
+touch fetch-geoip.sh
+echo "#!/bin/sh" >> fetch-geoip.sh
+echo 'echo "success"' >> fetch-geoip.sh
+chmod +x fetch-geoip.sh
+
+sed -i 's/msbuild/dotnet\ msbuild/g' ./Makefile ./packaging/functions.sh
chown -R root:root .
find -L . \
@@ -78,10 +92,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-make dependencies
-make all
+unshare -n make all TARGETPLATFORM=unix-generic RUNTIME=mono MSBUILD='dotnet msbuild -verbosity:m -nologo'
make prefix=/usr mandir=/usr/man bindir=/usr/games libdir=/usr/lib${LIBDIRSUFFIX} install DESTDIR=$PKG
make prefix=/usr mandir=/usr/man bindir=/usr/games libdir=/usr/lib${LIBDIRSUFFIX} install-linux-shortcuts DESTDIR=$PKG
+make prefix=/usr mandir=/usr/man bindir=/usr/games libdir=/usr/lib${LIBDIRSUFFIX} install-linux-appdata DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -96,4 +110,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/OpenRA/OpenRA.info b/games/OpenRA/OpenRA.info
index e885285b2e..6be42f4043 100644
--- a/games/OpenRA/OpenRA.info
+++ b/games/OpenRA/OpenRA.info
@@ -1,14 +1,14 @@
PRGNAM="OpenRA"
-VERSION="20190314"
+VERSION="20210321"
HOMEPAGE="http://www.openra.net/"
-DOWNLOAD="https://github.com/OpenRA/OpenRA/releases/download/release-20190314/OpenRA-release-20190314-source.tar.bz2 \
- http://repo.khronosschoty.org/Slackware/stuff/OpenRA/20190314/download.tar.gz \
- http://repo.khronosschoty.org/Slackware/stuff/OpenRA/20190314/GeoLite2-Country.mmdb.gz"
-MD5SUM="4ea1ba7d309bf0482979b5337677d2a3 \
- e890273530c23cb8571a729d2aced59d \
- 3639895811efb10ad54bf6b40980224e"
+DOWNLOAD="https://github.com/OpenRA/OpenRA/releases/download/release-20210321/OpenRA-release-20210321-source.tar.bz2 \
+ http://repo.schotynet.org/sources/openra/openra-deps.tar.gz \
+ http://repo.schotynet.org/sources/openra/IP2LOCATION-LITE-DB1.IPV6.BIN.ZIP"
+MD5SUM="38593fbcdda629561d8c0bc8ac1af402 \
+ 26b1855341dc15787c7b54945050095d \
+ ef52f92818ebc942ca98108e92a0b802"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="lua SDL2 mono"
+REQUIRES="lua mono dotnet-sdk-6.0"
MAINTAINER="khronosschoty"
EMAIL="khronosschoty@posteo.org"
diff --git a/games/OpenRA/fetch-thirdparty-deps.sh.new b/games/OpenRA/fetch-thirdparty-deps.sh.new
deleted file mode 100644
index c0f9ae9b5d..0000000000
--- a/games/OpenRA/fetch-thirdparty-deps.sh.new
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-####
-# This file must stay /bin/sh and POSIX compliant for BSD portability.
-# Copy-paste the entire script into http://shellcheck.net to check.
-####
-
-# Die on any error for Travis CI to automatically retry:
-set -e
-
-download_dir="${0%/*}/download"
-
-mkdir -p "${download_dir}"
-cd "${download_dir}"
-cd ..
-
-tar -xvf download.tar.gz
-