summaryrefslogtreecommitdiffstats
path: root/games/clonekeen/clonekeen.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/clonekeen/clonekeen.SlackBuild')
-rw-r--r--games/clonekeen/clonekeen.SlackBuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/games/clonekeen/clonekeen.SlackBuild b/games/clonekeen/clonekeen.SlackBuild
index 0dac845a1e..576da09235 100644
--- a/games/clonekeen/clonekeen.SlackBuild
+++ b/games/clonekeen/clonekeen.SlackBuild
@@ -2,15 +2,17 @@
# Slackware build script for clonekeen
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230108 bkw: BUILD=3, update .desktop file.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=clonekeen
VERSION=${VERSION:-8.4}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +24,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -55,17 +54,14 @@ rm -rf $SRCDIR
tar xvf $CWD/$PRGNAM-src-${VERSION/./}.tar.gz
cd $SRCDIR
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# Fix underlinking
sed -i "s|-lstdc++|-lstdc++ -lm|" src/Makefile
# Makefile doesn't use CFLAGS, ugh
-sed -i "/gcc/s/-O2/$SLKCFLAGS/" src/Makefile
+sed -i "/gcc/s/-O2/$SLKCFLAGS -fcommon/" src/Makefile
# Ugh. The src tarball ships with compiled .o files!
rm -f platform/*.o