summaryrefslogtreecommitdiffstats
path: root/games/egoboo
diff options
context:
space:
mode:
Diffstat (limited to 'games/egoboo')
-rw-r--r--games/egoboo/egoboo.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/egoboo/egoboo.SlackBuild b/games/egoboo/egoboo.SlackBuild
index 46dba3075d..24e62a207f 100644
--- a/games/egoboo/egoboo.SlackBuild
+++ b/games/egoboo/egoboo.SlackBuild
@@ -7,7 +7,7 @@
PRGNAM=egoboo
VERSION=${VERSION:-2.7.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,6 +52,9 @@ find . \
sed -i 's/\r//g' *.txt doc/*.txt
sed -i 's|${HOME}/.local|/usr|' game/$PRGNAM.sh
+# Fix whatever this problem is
+sed -i 's/-lGLU/-lGLU -lm/' game/Makefile.unix
+
# Compile and install program.
make -C game -f Makefile.unix OPT="$SLKCFLAGS -Wall" PREFIX=/usr
make -C game -f Makefile.unix PREFIX=$PKG/usr install