summaryrefslogtreecommitdiffstats
path: root/games/golly/golly.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/golly/golly.SlackBuild')
-rw-r--r--games/golly/golly.SlackBuild66
1 files changed, 37 insertions, 29 deletions
diff --git a/games/golly/golly.SlackBuild b/games/golly/golly.SlackBuild
index b510769780..2fd8c86b98 100644
--- a/games/golly/golly.SlackBuild
+++ b/games/golly/golly.SlackBuild
@@ -24,6 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Updated for golly 2.6 -- the source directory structure got changed a bit too!
+# 20201112 bkw: update for v4.0. Which adds a python3 dep.
# 20181211 bkw:
# - Take over maintenance.
# - i486 => i586.
@@ -35,7 +36,7 @@
# - Minor simplifications and cleanups.
PRGNAM=golly
-VERSION=${VERSION:-3.2}
+VERSION=${VERSION:-4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -88,45 +89,52 @@ if [ -z "$WXCONF" ]; then
exit 1
fi
-cd gui-wx/configure
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --with-wx-config="$WXCONF" \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --bindir=/usr/games \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
-
-cd ../icons
-
+SHAREDIR=/usr/share/games/$PRGNAM
+
+# 20201112 bkw: golly is the only project I ever heard of that
+# migrated from autotools back to a plain Makefile. So we can't build
+# versions < 4.0 any more, sorry.
+# We don't enable sound because it needs a proprietary non-free
+# library called irrKlang, which we don't (yet?) have on SBo and
+# I'm in no hurry to add.
+cd gui-wx
+cat > local-gtk.mk <<EOF
+WX_CONFIG = $WXCONF
+PYTHON = python3
+ENABLE_PERL = 1
+CXXFLAGS = $SLKCFLAGS
+GOLLYDIR = $SHAREDIR
+EOF
+
+make -f makefile-gtk
+
+cd ..
+mkdir -p $PKG/usr/games $PKG/$SHAREDIR
+install -s -m0755 $PRGNAM b$PRGNAM $PKG/usr/games
+cp -a Help Patterns Rules Scripts $PKG/$SHAREDIR
+
+# Don't need +x permissions on HTML pages, or even Lua/Python scripts.
+find $PKG/$SHAREDIR -type f -exec chmod 644 {} +
+
+cd gui-wx/icons
for i in 16 32 48; do
- convert appicon${i}.ico -resize ${i}x${i}! $PRGNAM-${i}.png
- mkdir -p $PKG/usr/share/icons/hicolor/${i}x${i}/apps/
- install -D -m 0644 $PRGNAM-${i}.png \
- $PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
+ convert appicon${i}.ico -resize ${i}x${i}! $PRGNAM-${i}.png
+ DIR=$PKG/usr/share/icons/hicolor/${i}x${i}/apps/
+ mkdir -p $DIR
+ install -m 0644 $PRGNAM-${i}.png $DIR/$PRGNAM.png
done
-convert appicon.xpm $PRGNAM.png
-install -D -m 0644 $PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
cd ../../docs
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a License.html ReadMe.html ToDo.html $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# 20181211 bkw: WARNING: gzip test failed on <...>/weekender-distaff.rle.gz
# Get rid of .gz extension for any non-gzipped data files.
-find $PKG/usr/share/$PRGNAM -name \*.gz | while read FILE; do
+find $PKG/$SHAREDIR -name \*.gz | while read FILE; do
if file $FILE | grep -qv gzip ; then
rename .gz '' "$FILE"
fi