summaryrefslogtreecommitdiffstats
path: root/games/gzdoom-legacy/compilefix.1.9.1.diff
diff options
context:
space:
mode:
Diffstat (limited to 'games/gzdoom-legacy/compilefix.1.9.1.diff')
-rw-r--r--games/gzdoom-legacy/compilefix.1.9.1.diff12
1 files changed, 12 insertions, 0 deletions
diff --git a/games/gzdoom-legacy/compilefix.1.9.1.diff b/games/gzdoom-legacy/compilefix.1.9.1.diff
new file mode 100644
index 0000000000..129886b3ea
--- /dev/null
+++ b/games/gzdoom-legacy/compilefix.1.9.1.diff
@@ -0,0 +1,12 @@
+diff -Naur gzdoom-g1.9.1/game-music-emu/CMakeLists.txt gzdoom-g1.9.1.patched/game-music-emu/CMakeLists.txt
+--- gzdoom-g1.9.1/game-music-emu/CMakeLists.txt 2016-02-23 05:34:50.000000000 -0500
++++ gzdoom-g1.9.1.patched/game-music-emu/CMakeLists.txt 2021-10-09 15:42:40.090569168 -0400
+@@ -84,7 +84,7 @@
+ if (__LIBGME_TEST_VISIBILITY)
+ # get the gcc version
+ exec_program(${CMAKE_CXX_COMPILER} ARGS --version OUTPUT_VARIABLE _gcc_version_info)
+- string (REGEX MATCH "[3-9]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
++ string (REGEX MATCH "[1-9][0-9]*\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
+
+ # gcc <4.1 had poor support for symbol visibility
+ if ((${_gcc_version} VERSION_GREATER "4.1") OR (${_gcc_version} VERSION_EQUAL "4.1"))