summaryrefslogtreecommitdiffstats
path: root/games/hatari/hatari.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/hatari/hatari.SlackBuild')
-rw-r--r--games/hatari/hatari.SlackBuild67
1 files changed, 44 insertions, 23 deletions
diff --git a/games/hatari/hatari.SlackBuild b/games/hatari/hatari.SlackBuild
index 35adec40d0..6dab2b4c9b 100644
--- a/games/hatari/hatari.SlackBuild
+++ b/games/hatari/hatari.SlackBuild
@@ -1,11 +1,24 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for hatari
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240419 bkw: update for v2.5.0.
+
+# 20230107 bkw:
+# - update for v2.4.1.
+# - fix bad icon symlink (symlinked a .svg to a .png filename, derp).
+# - coerce cmake to use python3, since hatariui now requires it.
+
+# 20210102 bkw: update for v2.3.1.
+# 20201218 bkw:
+# - update for v2.3.0. Can't build older versions, sorry.
+# - add new dep, python3.
+# - really fix the man pages.
+
# 20200426 bkw:
# - BUILD=2
# - Include support for IPF and CTR images (copy-protected images),
@@ -57,10 +70,13 @@
# reinstalling the package won't reset the default ROM.
# - add mime type and auto-associate ST disk images and executables.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=hatari
-VERSION=${VERSION:-2.2.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.5.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -70,11 +86,17 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
-TMP=${TMP-/tmp/SBo}
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+# Note: the -O2 here gets overridden by a -O3 that comes later on the
+# command line. Upstream tests with -O3 so it should be fine.
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
@@ -105,10 +127,11 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
# so let's have hatariui use that instead of failing.
patch -p1 < $CWD/hatariui-create-cfg-if-missing.diff
-# man page hadn't been updated since 2014, it says the config file lives
-# in the old ~/.hatari/ location. also fix a few typos and formatting
-# issues.
-patch -p1 < $CWD/manpage.diff
+# Man pages go in section 6, fix .TH and see-also refs. Also fix a few
+# typos and formatting issues.
+P="$CWD/manpage.$VERSION.diff"
+[ -e "$P" ] || P="$CWD/manpage.diff"
+patch -p1 < $P
# cmake doesn't support anything like --bindir, --mandir, --docdir. cheat
# a little.
@@ -118,9 +141,6 @@ sed -i \
-e "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION," \
CMakeLists.txt
-# man pages should be in section 6
-sed -i '/\.TH/s,"1","6",' doc/*.1 doc/fr/*.1 tools/*.1 python-ui/*.1
-
# Hard-code the doc path in the UI (we don't use /usr/share/doc/hatari)
sed -i \
-e "/path *= *path *+/s,=.*,= \"/usr/doc/$PRGNAM-$VERSION/\"," \
@@ -140,16 +160,25 @@ sed -i 's/ncurses\.h/&;readline.h/' cmake/FindReadline.cmake
# and libcapsimage 5.1 doesn't support a couple of typedefs that
# existed in 4.2.
+# 20201218 bkw: the source says '#include <caps/CapsLibAll.h>' but
+# we need <caps5/CapsLibAll.h>.
sed -i \
-e '1i#include <stdint.h>' \
-e 's,CapsLong,int32_t,g' \
-e 's,CapsULong,uint32_t,g' \
+ -e '/#include/s,caps/,caps5/,' \
src/floppy_ipf.c
# 20200427 bkw: upstream actually runs cmake directly in the source
# dir rather than the "mkdir build; cd build; cmake .." stuff from
# our template. I'm going to do it their way.
+# 20201218 bkw: I really should not have to tell cmake to look in
+# /usr/include for the libcapsimage headers, that is *the systemwide
+# default location* for includes, and has been since the 1970s. Grr.
cmake \
+ -DPYTHONINTERP_FOUND=ON \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DCAPSIMAGE_INCLUDE_DIR=/usr/include \
-DCMAKE_VERBOSE_MAKEFILE=TRUE \
$SDL2OPT \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
@@ -179,14 +208,6 @@ cp tools/hmsa/readme-hmsa.txt readme.txt gpl.txt \
doc/de/*.txt \
$DOCDIR
-# The UI has its own docs. These are actually used by the UI, so they
-# must be available in /usr/share/hatari (hence the symlinks).
-UIDOCDIR=$DOCDIR/${PRGNAM}ui
-mkdir -p $UIDOCDIR
-for i in README TODO release-notes.txt; do
- ln -s ../../../share/$PRGNAM/${PRGNAM}ui/$i $UIDOCDIR/$i
-done
-
# Someone might find the French man page useful. It's in utf-8, so
# put it in the right dir.
mkdir -p $PKG/usr/man/fr.UTF-8/man6 $PKG/usr/man/fr/man6
@@ -208,7 +229,7 @@ for i in $PKG/usr/share/icons/hicolor/[0-9]*; do
done
ln -s application-x-st-disk-image.svg \
- $PKG/usr/share/icons/hicolor/scalable/mimetypes/x-st-executable.png
+ $PKG/usr/share/icons/hicolor/scalable/mimetypes/x-st-executable.svg
# Don't symlink emutos to tos here, do it conditionally in doinst.sh.
( cd $PKG/usr/share/$PRGNAM && mv tos.img emutos.img )
@@ -223,4 +244,4 @@ sed -e "s,@WITHSDL@,$WITHSDL," \
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE