summaryrefslogtreecommitdiffstats
path: root/games/maelstrom/maelstrom.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/maelstrom/maelstrom.SlackBuild')
-rw-r--r--games/maelstrom/maelstrom.SlackBuild67
1 files changed, 43 insertions, 24 deletions
diff --git a/games/maelstrom/maelstrom.SlackBuild b/games/maelstrom/maelstrom.SlackBuild
index e1d1c842e9..88cddc94c8 100644
--- a/games/maelstrom/maelstrom.SlackBuild
+++ b/games/maelstrom/maelstrom.SlackBuild
@@ -1,11 +1,16 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for maelstrom
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211020 bkw: upstream's first update since 2002! ported to SDL2!
+# - update for v3.0.7.
+# - new-style icons.
+# - update URLs in perl script and man page.
+
# 20180627 bkw: fix compile with gcc 8 (for -current).
# 20160730 bkw:
@@ -14,10 +19,13 @@
# - Remove warnings about multiplayer not working on 64-bit, it
# works now.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=maelstrom
-VERSION=${VERSION:-3.0.6}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.0.7}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=Maelstrom
@@ -29,7 +37,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -57,18 +69,11 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# Fix 64-bit compile issue (not needed on 32-bit, but does no harm)
-patch -p1 < $CWD/compile_fix.diff
-
-# Install game data in /usr/share/games/Maelstrom, not /usr/games/Maelstrom
-# (also make `make install' support DESTDIR properly!)
-patch -p1 < $CWD/install_dirs.diff
+# Look for game data in /usr/share/games/Maelstrom, not /usr/games/Maelstrom
+sed -i '/GAME_INSTALLDIR=.*games/s,/games,/share/games,' configure
# 20180627 bkw: It seems structs and typedefs now share a namespace
# in gcc-8.1's g++. So rename this struct to keep the compiler happy
@@ -84,8 +89,13 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
-strip --strip-unneeded $PKG/usr/games/*
+
+# 20211020 bkw: 3.0.7's make install is hard to deal with, do without.
+GAMEDIR=$PKG/usr/share/games/$SRCNAM
+mkdir -p $PKG/usr/games $GAMEDIR
+cp -a Images Maelstrom_{Fonts,Sounds,Sprites} icon.* $GAMEDIR
+rm $GAMEDIR/Images/Makefile*
+install -s -m0755 $SRCNAM $SRCNAM-netd $PKG/usr/games
# CLI users would probably prefer to type 'maelstrom', not 'Maelstrom'
( cd $PKG/usr/games && ln -s $SRCNAM $PRGNAM )
@@ -95,6 +105,15 @@ install -m0755 -o root -g root $CWD/maelstrom_addon_package.pl $PKG/usr/games
mkdir -p $PKG/usr/share/applications
cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+# upstream's icon is 48x48, resize
+for i in 16 32 48 64; do
+ px=$( basename $i | cut -d. -f1 )
+ size=${px}x${px}
+ dir=$PKG/usr/share/icons/hicolor/$size/apps
+ mkdir -p $dir
+ convert -resize $size icon.xpm $dir/$PRGNAM.png
+done
+
mkdir -p $PKG/usr/share/pixmaps
( cd $PKG/usr/share/pixmaps ; ln -s ../games/$SRCNAM/icon.xpm $PRGNAM.xpm )
@@ -104,15 +123,15 @@ gzip -9c $CWD/$SRCNAM.6 > $PKG/usr/man/man6/$SRCNAM.6.gz
ln -s $SRCNAM.6.gz $PRGNAM.6.gz
ln -s $SRCNAM.6.gz $SRCNAM-netd.6.gz )
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-make install_gamedocs target=$PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-# Why does `make install' install this?
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Docs/Makefile
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a Changelog *.txt Docs $PKGDOC
+rm -f $PKGDOC/Docs/Makefile*
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE