summaryrefslogtreecommitdiffstats
path: root/games/meandmyshadow/meandmyshadow.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/meandmyshadow/meandmyshadow.SlackBuild')
-rw-r--r--games/meandmyshadow/meandmyshadow.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/meandmyshadow/meandmyshadow.SlackBuild b/games/meandmyshadow/meandmyshadow.SlackBuild
index 3f732b8519..63bb8b3bcf 100644
--- a/games/meandmyshadow/meandmyshadow.SlackBuild
+++ b/games/meandmyshadow/meandmyshadow.SlackBuild
@@ -6,7 +6,7 @@
PRGNAM=meandmyshadow
VERSION=${VERSION:-0.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,6 +57,9 @@ sed -i -e '/^Version/d' -e 's|;Game;|;|' meandmyshadow.desktop
# SLKCFLAGS are respected.
sed -i "s|-Wall -g|& $SLKCFLAGS|" CMakeLists.txt
+# From upstream. Fix for building with gcc 4.7.x.
+patch -p1 < $CWD/gcc-4.7.patch
+
mkdir -p build
cd build
cmake -G "Unix Makefiles" \