summaryrefslogtreecommitdiffstats
path: root/games/mrboom/mrboom.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/mrboom/mrboom.SlackBuild')
-rw-r--r--games/mrboom/mrboom.SlackBuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/games/mrboom/mrboom.SlackBuild b/games/mrboom/mrboom.SlackBuild
index 4118447699..2c16cbd408 100644
--- a/games/mrboom/mrboom.SlackBuild
+++ b/games/mrboom/mrboom.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mrboom
-# Copyright 2017-2019 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2017-2020 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mrboom
-VERSION=${VERSION:-4.8}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-4.9}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
SRCNAM=mrboom-libretro
@@ -72,6 +72,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p0 < $CWD/Makefile.patch
+sed -i "s|^GIT_VERSION :=.*|GIT_VERSION := \" ${VERSION}\"|" Makefile
+
if pkg-config --exists sdl2; then
make mrboom LIBSDL2=1
@@ -82,6 +85,10 @@ if pkg-config --exists sdl2; then
install -m 0644 Assets/$PRGNAM.desktop $PKG/usr/share/applications
install -m 0644 $CWD/mrboom.svg $PKG/usr/share/pixmaps
+ for i in 16x16 32x32 48x48 256x256; do
+ install -D -m0644 Assets/hicolor/$i/apps/$PRGNAM.png $PKG/usr/share/icons/hicolor/$i/apps/$PRGNAM.png
+ done
+
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
fi