summaryrefslogtreecommitdiffstats
path: root/games/nethack/files/nethack-x11.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/nethack/files/nethack-x11.patch')
-rw-r--r--games/nethack/files/nethack-x11.patch82
1 files changed, 82 insertions, 0 deletions
diff --git a/games/nethack/files/nethack-x11.patch b/games/nethack/files/nethack-x11.patch
new file mode 100644
index 0000000000..e6fb890e5d
--- /dev/null
+++ b/games/nethack/files/nethack-x11.patch
@@ -0,0 +1,82 @@
+diff -U 3 -dHrN -- nethack-3.4.3-enviro/include/config.h nethack-3.4.3-x11/include/config.h
+--- nethack-3.4.3-enviro/include/config.h 2007-01-02 22:38:51.000000000 -0600
++++ nethack-3.4.3-x11/include/config.h 2007-01-02 23:10:07.000000000 -0600
+@@ -43,7 +43,7 @@
+ * Some combinations make no sense. See the installation document.
+ */
+ #define TTY_GRAPHICS /* good old tty based graphics */
+-/* #define X11_GRAPHICS */ /* X11 interface */
++#define X11_GRAPHICS /* X11 interface */
+ /* #define QT_GRAPHICS */ /* Qt interface */
+ /* #define GNOME_GRAPHICS */ /* Gnome interface */
+ /* #define MSWIN_GRAPHICS */ /* Windows NT, CE, Graphics */
+@@ -126,7 +126,7 @@
+ * would allow:
+ * xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
+ */
+-/* # define USE_XPM */ /* Disable if you do not have the XPM library */
++# define USE_XPM /* Disable if you do not have the XPM library */
+ # ifdef USE_XPM
+ # define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
+ # endif
+diff -U 3 -dHrN -- nethack-3.4.3-enviro/sys/unix/Makefile.src nethack-3.4.3-x11/sys/unix/Makefile.src
+--- nethack-3.4.3-enviro/sys/unix/Makefile.src 2007-01-02 22:40:09.000000000 -0600
++++ nethack-3.4.3-x11/sys/unix/Makefile.src 2007-01-02 23:20:01.000000000 -0600
+@@ -151,8 +151,8 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
+-LFLAGS =
++CFLAGS = -O -I../include -I/usr/X11R6/include
++LFLAGS = -L/usr/X11R6/lib
+
+ # The Qt and Be window systems are written in C++, while the rest of
+ # NetHack is standard C. If using Qt, uncomment the LINK line here to get
+@@ -214,8 +214,8 @@
+
+ #
+ #
+-WINSRC = $(WINTTYSRC)
+-WINOBJ = $(WINTTYOBJ)
++WINSRC = $(WINTTYSRC) $(WINX11SRC)
++WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
+
+ # on some systems the termcap library is in -ltermcap or -lcurses
+ # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
+@@ -235,9 +235,9 @@
+ #
+ # libraries for X11
+ # If USE_XPM is defined in config.h, you will also need -lXpm here.
+-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
++# WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
+ # WINX11LIB = -lXaw -lXmu -lXt -lX11
+-# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
++WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
+ # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
+ #
+ # libraries for Qt
+@@ -255,7 +255,7 @@
+ # libraries for BeOS
+ WINBELIB = -lbe
+
+-WINLIB = $(WINTTYLIB)
++WINLIB = $(WINTTYLIB) $(WINX11LIB)
+
+ # any other strange libraries your system needs (for Sysunix only -- the more
+ # specialized targets should already be right)
+diff -U 3 -dHrN -- nethack-3.4.3-enviro/sys/unix/Makefile.top nethack-3.4.3-x11/sys/unix/Makefile.top
+--- nethack-3.4.3-enviro/sys/unix/Makefile.top 2007-01-02 22:36:23.000000000 -0600
++++ nethack-3.4.3-x11/sys/unix/Makefile.top 2007-01-02 23:12:32.000000000 -0600
+@@ -40,9 +40,9 @@
+ SHELLDIR = $(PREFIX)/games
+
+ # per discussion in Install.X11 and Install.Qt
+-VARDATND =
++# VARDATND =
+ # VARDATND = x11tiles NetHack.ad pet_mark.xbm
+-# VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
++VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
+ # for Atari/Gem
+ # VARDATND = nh16.img title.img GEM_RSC.RSC rip.img
+ # for BeOS