summaryrefslogtreecommitdiffstats
path: root/games/odamex
diff options
context:
space:
mode:
Diffstat (limited to 'games/odamex')
-rw-r--r--games/odamex/README25
-rw-r--r--games/odamex/doinst.sh5
-rw-r--r--games/odamex/odamex.SlackBuild118
-rw-r--r--games/odamex/odamex.info12
-rw-r--r--games/odamex/use_bundled_portmidi.diff20
5 files changed, 130 insertions, 50 deletions
diff --git a/games/odamex/README b/games/odamex/README
index b97c5c769a..548ac5bb2e 100644
--- a/games/odamex/README
+++ b/games/odamex/README
@@ -1,14 +1,18 @@
+odamex: odamex (Online Doom Multiplayer Experience)
+
Odamex (Online Doom Multiplayer Experience) is a modification of DOOM
-to allow players to compete with each other over the Internet using the
-client/server architecture.
+to allow players to compete with each other over the Internet using
+the client/server architecture.
-To hear in-game music, install either eawpats or freepats, and make sure
-the Options -> Sound Options -> MIDI System Backend option is set to
-"SDL Mixer".
+To hear in-game music, install either eawpats or freepats, and make
+sure the Options -> Sound Options -> MIDI System Backend option is set
+to "SDL Mixer". If this doesn't work, make sure you've updated to the
+latest eawpats or freepats, and that the symlink at /etc/timidity.cfg
+is valid (points to "timidity/eawpats.cfg" or "timidity/crude.cfg").
-Optional dependency: If portmidi is installed, odamex will be built with
-it. This allows odamex's in-game music to be directed to a separate MIDI
-synthesizer application, or a hardware MIDI synth.
+Optional dependency: If portmidi is installed, odamex will be built
+with it. This allows odamex's in-game music to be directed to a
+separate MIDI synthesizer application, or a hardware MIDI synth.
You'll also need the game data (WAD file) from one of the following:
@@ -25,8 +29,3 @@ all lowercase (doom.wad) or all uppercase (DOOM.WAD).
Optional dependency: miniupnpc (auto-detected at build time). This
adds support for UPnP to odasrv (the odamex server). It has no effect
on odamex (the client) or odalaunch (the launcher).
-
-Note: If you get compile errors relating to wxIntPtr not being defined,
-upgrade your wxPython or wxGTK package to at least version 2.8.12.0. If
-for some reason you don't want to do this, see the comments in the
-SlackBuild for a dirty hack that might work instead.
diff --git a/games/odamex/doinst.sh b/games/odamex/doinst.sh
index 4e8ba7071d..3e5691a052 100644
--- a/games/odamex/doinst.sh
+++ b/games/odamex/doinst.sh
@@ -2,3 +2,8 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/odamex/odamex.SlackBuild b/games/odamex/odamex.SlackBuild
index 539ae20d6a..9a52a368f5 100644
--- a/games/odamex/odamex.SlackBuild
+++ b/games/odamex/odamex.SlackBuild
@@ -1,11 +1,27 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for odamex
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20231120 bkw: update for v10.4.0.
+# 20230707 bkw: FTBFS, when agar is installed. our agar is 1.7.0,
+# apparently too new for odamex-10.3.0. agar was added to SBo
+# in May 2023; until then, odamex didn't have ag-odalaunch and
+# it wasn't a problem. so just disable agar completely.
+# 20230110 bkw: update for v10.3.0. SDL2 builds are still broken,
+# game segfaults after picking an IWAD. SDL 1.2 builds are OK.
+# 20220319 bkw: fix build on 32-bit.
+# 20220208 bkw: BUILD=3, add the missing .diff...
+# 20211231 bkw: BUILD=2.
+# - the SDL2 segfault will likely be fixed soon (reported to PV, along
+# with a patch). add SDL2 environment variable, default to no.
+
+# 20211028 bkw: update for v0.9.5.
+# - had to switch to SDL 1 to avoid SDL2_Mixer-related segfaults.
+# unfortunately I can't get the music to work with SDL 1...
# 20201024 bkw: update for v0.8.3.
# 20191201 bkw: update for v0.8.1.
@@ -21,10 +37,13 @@
# - get rid of hard-coded /usr/share/games/doom, no longer needed
# - include sample orasrv.cfg from 0.6.4 source (it's gone from 0.7.0)
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=odamex
-VERSION=${VERSION:-0.8.3}
+VERSION=${VERSION:-10.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -34,7 +53,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -67,31 +90,47 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-src-$VERSION
-tar xvf $CWD/$PRGNAM-src-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-src-$VERSION.tar.xz
cd $PRGNAM-src-$VERSION
chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# Every file in 0.9.5 is +x, and none of them need to be!
+# Do not revert to template.
+find . -type f -exec chmod 644 {} \+
+find . -type d -exec chmod 755 {} \+
+
+SDL12ARG=ON
+[ "${SDL2:-no}" = "yes" ] && SDL12ARG=OFF
+
+# 20220101 bkw: do not use systemwide install of portmidi, if it exists.
+# This is to avoid a hidden portmidi dependency breaking the odamex
+# binary when portmidi gets removed or upgraded.
+patch -p1 < $CWD/use_bundled_portmidi.diff
# Make the launcher look in /usr/games for the odamex binary rather
# than the current directory. User can override with the settings
# dialog, this just sets the default.
-sed -i \
- '/launchercfg_s.odamex_directory *= */s,wxGetCwd(),wxString::FromAscii("/usr/games"),' \
- odalaunch/src/dlg_main.cpp
+sed -i 's,OdaGetInstallDir(),"/usr/games",g' \
+ odalaunch/src/dlg_main.cpp \
+ odalaunch/src/dlg_config.cpp
+
+# 20220319 bkw: cmake brokenness, fix manually.
+sed -i '/-march=pentium-m/d' client/CMakeLists.txt
+SLKCFLAGS+=" -msse -msse2"
-# 20201024 bkw: Not sure why make is exiting with nonzero status after
-# linking odalaunch. There are no error messages. Adding "-i" to the
-# make command line is a band-aid for this.
+rm -rf build
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_BINDIR=games \
-DwxWidgets_CONFIG_EXECUTABLE=$WXCONFIG \
+ -DUSE_SDL12=$SDL12ARG \
+ -DNO_AG-ODALAUNCH_TARGET=ON \
-DCMAKE_BUILD_TYPE=Release ..
- make -i VERBOSE=1
+ make VERBOSE=1
cd ..
# cmake-based odamex lacks a 'make install' target, do it manually.
@@ -101,36 +140,51 @@ install -s -m0755 build/client/$PRGNAM $PKG/usr/games
install -s -m0755 build/server/odasrv $PKG/usr/games
install -s -m0755 build/odalaunch/odalaunch $PKG/usr/games
-mkdir -p $PKG/usr/share/games/doom
-
-# wad file has moved in the source tree, accomodate either version
-WAD="$PRGNAM.wad"
-[ -e "wad/$PRGNAM.wad" ] && WAD="wad/$PRGNAM.wad"
-install -m0644 $WAD $PKG/usr/share/games/doom
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/tech
-cp -a CHANGELOG LICENSE MAINTAINERS README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/odasrv.cfg > $PKG/usr/doc/$PRGNAM-$VERSION/odasrv.cfg.sample
-install -m0644 documentation/tech/* $PKG/usr/doc/$PRGNAM-$VERSION/tech
-
# Man page created for this slackbuild
-mkdir -p $PKG/usr/man/man6
-gzip -9c < $CWD/$PRGNAM.6 > $PKG/usr/man/man6/$PRGNAM.6.gz
+MANDIR=$PKG/usr/man/man6
+mkdir -p $MANDIR
+gzip -9c < $CWD/$PRGNAM.6 > $MANDIR/$PRGNAM.6.gz
+for i in odasrv odalaunch; do
+ ln -s $PRGNAM.6.gz $MANDIR/$i.6.gz
+done
# Desktop stuff
mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
for exe in $PRGNAM odasrv odalaunch; do
- sed -e '/^Encoding/d' -e 's,/usr/share/doom,/usr/share/games/doom,' \
+ # make these validate and call the correct binary
+ sed -e '/^Encoding/d' -e 's, -waddir.*,,' -e 's,Exec=,&/usr/games/,' \
< installer/arch/$exe.desktop \
> $PKG/usr/share/applications/$exe.desktop
- cat media/icon_${exe}_512.png > $PKG/usr/share/pixmaps/$exe.png
+
+ # use upstream's icons
+ for i in media/icon_${exe}_*.png; do
+ px=$( basename $i | cut -d. -f1 | cut -d_ -f3 )
+ size=${px}x${px}
+ dir=$PKG/usr/share/icons/hicolor/$size/apps
+ mkdir -p $dir
+ cat $i > $dir/$exe.png
+ done
+
+ # make old-school icon, too
+ convert -resize 48x48 media/icon_${exe}_512.png $PKG/usr/share/pixmaps/$exe.png
done
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# 20211027 bkw: In 0.9.5, upstream doesn't ship the wad. It expects
+# to build it using deutex. Easier to use a prebuilt one, from their
+# windows package.
+WADDIR=$PKG/usr/share/games/doom
+mkdir -p $WADDIR
+unzip -p $CWD/$PRGNAM-win32-$VERSION.zip $PRGNAM.wad > $WADDIR/$PRGNAM.wad
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a CHANGELOG LICENSE MAINTAINERS README.md documentation/tech $PKGDOC
+cat $CWD/odasrv.cfg > $PKGDOC/odasrv.cfg.sample
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/odamex/odamex.info b/games/odamex/odamex.info
index 2da96d07f2..facad2dc17 100644
--- a/games/odamex/odamex.info
+++ b/games/odamex/odamex.info
@@ -1,10 +1,12 @@
PRGNAM="odamex"
-VERSION="0.8.3"
-HOMEPAGE="http://odamex.net/"
-DOWNLOAD="http://downloads.sourceforge.net/odamex/odamex-src-0.8.3.tar.bz2"
-MD5SUM="c096604173a0d48946f877483520dec1"
+VERSION="10.4.0"
+HOMEPAGE="https://odamex.net/"
+DOWNLOAD="https://downloads.sourceforge.net/project/odamex/Odamex/10.4.0/odamex-src-10.4.0.tar.xz \
+ https://downloads.sourceforge.net/project/odamex/Odamex/10.4.0/odamex-win32-10.4.0.zip"
+MD5SUM="b2de35cbe4930ad63c464d497c3af99a \
+ 6b446626b2390e5415ed54be3a326c09"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="wxGTK3"
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"
diff --git a/games/odamex/use_bundled_portmidi.diff b/games/odamex/use_bundled_portmidi.diff
new file mode 100644
index 0000000000..2fffcc2737
--- /dev/null
+++ b/games/odamex/use_bundled_portmidi.diff
@@ -0,0 +1,20 @@
+diff -Naur odamex-src-0.9.5/client/CMakeLists.txt odamex-src-0.9.5.patched/client/CMakeLists.txt
+--- odamex-src-0.9.5/client/CMakeLists.txt 2021-09-08 23:18:23.000000000 -0400
++++ odamex-src-0.9.5.patched/client/CMakeLists.txt 2022-01-01 14:36:43.305448361 -0500
+@@ -65,8 +65,6 @@
+
+ # PortMidi
+ if(ENABLE_PORTMIDI)
+- find_package(PortMidi)
+- if(NOT PORTMIDI_FOUND)
+ # build the PortMidi library
+ set(PORTMIDI_LIBRARY "portmidi")
+ set(PORTMIDI_LIBRARIES ${PORTMIDI_LIBRARY})
+@@ -107,7 +105,6 @@
+ add_library(${PORTMIDI_LIBRARY} STATIC ${PORTMIDI_SOURCES} ${PORTMIDI_HEADERS})
+ target_link_libraries(${PORTMIDI_LIBRARY} ${PM_NEEDED_LIBS})
+ message(STATUS "portmidi will be built and staticaly linked when compiling the client application.")
+- endif()
+
+ add_definitions(-DPORTMIDI)
+ include_directories(${PORTMIDI_INCLUDE_DIR})