summaryrefslogtreecommitdiffstats
path: root/games/oolite/oolite.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/oolite/oolite.SlackBuild')
-rw-r--r--games/oolite/oolite.SlackBuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/games/oolite/oolite.SlackBuild b/games/oolite/oolite.SlackBuild
index e93dc5ce54..3734a5cf98 100644
--- a/games/oolite/oolite.SlackBuild
+++ b/games/oolite/oolite.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for oolite
-# Copyright 2016 - 2020 Johannes Schoepfer, Germany
+# Copyright 2016 - 2022 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,6 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Modified by the SlackBuilds.org project.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=oolite
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -69,9 +68,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf oolite-source-$VERSION
-tar vxf $CWD/oolite-source-$VERSION.tar.bz2
-cd oolite-source-$VERSION
+rm -rf $PRGNAM-source-$VERSION
+tar vxf $CWD/$PRGNAM-source-$VERSION.tar.bz2
+cd $PRGNAM-source-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -79,17 +78,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Make sure only system libs may be used
+# Make sure only system libs will be used
rm deps/Linux-deps/x86*/lib/*
+rm -rf deps/Linux-deps/include/*
source /usr/share/GNUstep/Makefiles/GNUstep.sh
export GNUSTEP_MAKEFILES=/usr/share/GNUstep/Makefiles
-## Link to espeak-ng instead of espeak
-# -e "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" \
sed -i \
- -e "/ADDITIONAL_OBJCFLAGS/s/=/= -fobjc-exceptions ${SLKCFLAGS}/" \
+ -e "/ADDITIONAL_OBJCFLAGS/s/=/= ${SLKCFLAGS}/" \
-e "s/-mtune=generic//g" \
- -e "s/ -lpng / -l:libpng14.so.14 /g" \
+ -e "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" \
GNUmakefile
make -f Makefile ESPEAK=yes use_deps=no debug=no release