summaryrefslogtreecommitdiffstats
path: root/games/ppsspp
diff options
context:
space:
mode:
Diffstat (limited to 'games/ppsspp')
-rw-r--r--games/ppsspp/README16
-rw-r--r--games/ppsspp/patch-system-libpng16.patch83
-rw-r--r--games/ppsspp/ppsspp-qt.desktop6
-rw-r--r--games/ppsspp/ppsspp.SlackBuild34
-rw-r--r--games/ppsspp/ppsspp.desktop6
-rw-r--r--games/ppsspp/ppsspp.info28
-rw-r--r--games/ppsspp/ppsspp_libretro.information19
7 files changed, 45 insertions, 147 deletions
diff --git a/games/ppsspp/README b/games/ppsspp/README
index fa2355a9fae..addf8a0eb89 100644
--- a/games/ppsspp/README
+++ b/games/ppsspp/README
@@ -2,15 +2,13 @@ PPSSPP can run your PSP games on your PC in full HD resolution. It can
even upscale textures that would otherwise be too blurry as they were
made for the small screen of the original PSP.
-* Play in HD resolutions and more
-* Play on a tablet for big-screen mobile gaming
-* Customize on-screen touch controls or use an external controller or keyboard
-* Save and restore game state anywhere, anytime
-* Crank up the anisotropic filtering and texture scaling
-* Continue where you left off by transferring saves from your real PSP
+* Play in HD resolutions and more * Play on a tablet for big-screen
+mobile gaming * Customize on-screen touch controls or use an external
+controller or keyboard * Save and restore game state anywhere, anytime
+* Crank up the anisotropic filtering and texture scaling * Continue
+where you left off by transferring saves from your real PSP
snappy is an optional dependency.
-QT=on will enable QT GUI and require qt5 installed (default is 'QT=off').
-
-This builds the application and the Libretro core (for use with RetroArch).
+QT=on will enable QT GUI and require qt5 installed (default is
+'QT=off').
diff --git a/games/ppsspp/patch-system-libpng16.patch b/games/ppsspp/patch-system-libpng16.patch
deleted file mode 100644
index 442a1c4b818..00000000000
--- a/games/ppsspp/patch-system-libpng16.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dc0676d3d..72bfe8b07 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -658,9 +658,10 @@ else()
- set(LIBZIP_LIBRARY libzip)
- endif()
-
--# FindPNG does a few things we don't want. So do it ourselves. Fixed to libpng17
--find_path(PNG_PNG_INCLUDE_DIR NAMES "libpng17/png.h")
--find_library(PNG_LIBRARY NAMES png17 libpng17)
-+find_package(PkgConfig)
-+pkg_check_modules(PNG libpng>=1.6)
-+set(PNG_LIBRARY ${PNG_LIBRARIES})
-+set(PNG_PNG_INCLUDE_DIR ${PNG_INCLUDE_DIRS})
- find_package(PackageHandleStandardArgs)
- find_package_handle_standard_args(PNG REQUIRED_VARS PNG_LIBRARY PNG_PNG_INCLUDE_DIR)
- if(PNG_FOUND)
-diff --git a/Core/Debugger/WebSocket/GPUBufferSubscriber.cpp b/Core/Debugger/WebSocket/GPUBufferSubscriber.cpp
-index 67b13d85b..aff77aae3 100644
---- a/Core/Debugger/WebSocket/GPUBufferSubscriber.cpp
-+++ b/Core/Debugger/WebSocket/GPUBufferSubscriber.cpp
-@@ -17,7 +17,7 @@
-
- #include <algorithm>
- #ifndef USING_QT_UI
--#include <libpng17/png.h>
-+#include <png.h>
- #include <zlib.h>
- #endif
- #include "data/base64.h"
-diff --git a/Core/Screenshot.cpp b/Core/Screenshot.cpp
-index 2a2ddcf27..a90f3c542 100644
---- a/Core/Screenshot.cpp
-+++ b/Core/Screenshot.cpp
-@@ -21,7 +21,7 @@
- #ifdef USING_QT_UI
- #include <QtGui/QImage>
- #else
--#include <libpng17/png.h>
-+#include <png.h>
- #include "ext/jpge/jpge.h"
- #endif
-
-diff --git a/Core/TextureReplacer.cpp b/Core/TextureReplacer.cpp
-index 6087c87ae..b9a9a5abd 100644
---- a/Core/TextureReplacer.cpp
-+++ b/Core/TextureReplacer.cpp
-@@ -18,7 +18,7 @@
- #ifdef USING_QT_UI
- #include <QtGui/QImage>
- #else
--#include <libpng17/png.h>
-+#include <png.h>
- #endif
-
- #include <algorithm>
-diff --git a/ext/native/image/png_load.cpp b/ext/native/image/png_load.cpp
-index 41e90a88e..0b07801b6 100644
---- a/ext/native/image/png_load.cpp
-+++ b/ext/native/image/png_load.cpp
-@@ -5,7 +5,7 @@
- #ifdef USING_QT_UI
- #include <QtGui/QImage>
- #else
--#include "libpng17/png.h"
-+#include "png.h"
- #endif
-
- #include "png_load.h"
-diff --git a/ext/native/tools/atlastool.cpp b/ext/native/tools/atlastool.cpp
-index 804d4198b..e95eb3b56 100644
---- a/ext/native/tools/atlastool.cpp
-+++ b/ext/native/tools/atlastool.cpp
-@@ -18,7 +18,7 @@
- // line height
- // dist-per-pixel
-
--#include <libpng17/png.h>
-+#include <png.h>
- #include <ft2build.h>
- #include <freetype/ftbitmap.h>
- #include <set>
diff --git a/games/ppsspp/ppsspp-qt.desktop b/games/ppsspp/ppsspp-qt.desktop
index e89a5f950f3..4bdd11d58a0 100644
--- a/games/ppsspp/ppsspp-qt.desktop
+++ b/games/ppsspp/ppsspp-qt.desktop
@@ -1,7 +1,9 @@
[Desktop Entry]
-Name=ppsspp-qt
-Exec=ppsspp-qt
+Version=1.0
+Name=PPSSPP (Qt)
+Exec=ppsspp-qt %f
Icon=ppsspp
Type=Application
+GenericName=PSP Emulator
Comment=ppsspp (fast and portable PSP emulator)
Categories=Game
diff --git a/games/ppsspp/ppsspp.SlackBuild b/games/ppsspp/ppsspp.SlackBuild
index 4b12d52afb6..48a92375784 100644
--- a/games/ppsspp/ppsspp.SlackBuild
+++ b/games/ppsspp/ppsspp.SlackBuild
@@ -23,8 +23,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20210218 bkw: modified by SlackBuilds.org. Use correct filenames
+# in the github URLs for the 'submodules'. This is needed because
+# we don't get to decide what user-agent the user downloads files
+# with. If the Content-Disposition header is honored (e.g. files
+# downloaded with a web browser), this build failed.
+
PRGNAM=ppsspp
-VERSION=${VERSION:-1.9.4}
+VERSION=${VERSION:-1.10.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -66,15 +72,15 @@ cd $PRGNAM-$VERSION
# The submodules are in a separate archive. This is equivalent to
# git submodule update --init --recursive
-tar -xvf $CWD/hrydgard-glslang-2.3.r2575.gf9d08a25.tar.gz \
+tar -xvf $CWD/glslang-d0850f8*.tar.gz \
-C ext/glslang --strip-components=1
-tar -xvf $CWD/hrydgard-ppsspp-lang-a95fd4974c436a1a07455c5beef4a12f9f47b811.tar.gz \
+tar -xvf $CWD/ppsspp-lang-1c64b8f*.tar.gz \
-C assets/lang --strip-components=1
-tar -xvf $CWD/KhronosGroup-SPIRV-Cross-2019.05.20.r60.ga1f7c8dc.tar.gz \
+tar -xvf $CWD/SPIRV-Cross-a1f7c8d*.tar.gz \
-C ext/SPIRV-Cross --strip-components=1
-tar -xvf $CWD/Kingcom-armips-v0.9.r134.g7885552.tar.gz \
+tar -xvf $CWD/armips-7885552*.tar.gz \
-C ext/armips --strip-components=1
-tar -xvf $CWD/hrydgard-ppsspp-ffmpeg-90701640c7f458461310b54e7d4041230e2d5d5a.tar.gz \
+tar -xvf $CWD/ppsspp-ffmpeg-55147e5*.tar.gz \
--exclude '*/Windows*' --exclude '*/android' \
--exclude '*/ios' --exclude '*/blackberry'\
--exclude '*/macosx' --exclude '*/wiiu' \
@@ -94,9 +100,8 @@ sed -i 's/VERSION 3.6/VERSION 3.5.2/' CMakeLists.txt
# Don't force explicit ccache invocation.
sed -i -e '/include(ccache)/d' CMakeLists.txt
-# Make build glue accept libpng 1.6.x and don't hardcode suffix
-patch --forward --strip=1 \
- --input=$CWD/patch-system-libpng16.patch
+# set git-version
+sed -i "s/unknown/${VERSION}/" git-version.cmake
mkdir -p build-qt build-sdl
@@ -110,7 +115,6 @@ if [ "$QT" = "on" ]; then
-DCMAKE_SKIP_RPATH=TRUE \
-Wno-dev \
-DUSING_QT_UI=ON \
- -DLIBRETRO=ON \
-DUSE_SYSTEM_LIBZIP=ON \
-DUSE_DISCORD=OFF \
-DCMAKE_BUILD_TYPE=Release ..
@@ -129,13 +133,13 @@ cmake \
-Wno-dev \
-DUSING_QT_UI=OFF \
-DHEADLESS='ON' \
- -DLIBRETRO=ON \
-DUSE_SYSTEM_LIBZIP=ON \
-DUSE_DISCORD=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
cd ..
-install -Dm755 build-sdl/PPSSPPHeadless $PKG/usr/games/ppsspp
+install -Dm755 build-sdl/PPSSPPHeadless $PKG/usr/games/ppsspp-headless
+install -Dm755 build-sdl/PPSSPPSDL $PKG/usr/games/ppsspp-sdl
mkdir -p $PKG/usr/{games,share/{applications,icons/hicolor,pixmaps,ppsspp}}
install -Dm644 $CWD/ppsspp.desktop $PKG/usr/share/applications/ppsspp.desktop
@@ -143,15 +147,11 @@ cp -r assets $PKG/usr/share/ppsspp
cp -r icons/hicolor/* $PKG/usr/share/icons/hicolor
cp icons/icon-512.svg $PKG/usr/share/pixmaps/ppsspp.svg
-mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info
-cp build-sdl/lib/ppsspp_libretro.so $PKG/usr/lib${LIBDIRSUFFIX}/libretro
-cp $CWD/ppsspp_libretro.information $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.TXT README.md korean.txt chinese.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -v LICENSE.TXT README.md history.md headless/headless.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/games/ppsspp/ppsspp.desktop b/games/ppsspp/ppsspp.desktop
index 74dd7f4cde5..63e50e308a5 100644
--- a/games/ppsspp/ppsspp.desktop
+++ b/games/ppsspp/ppsspp.desktop
@@ -1,7 +1,9 @@
[Desktop Entry]
-Name=ppsspp
-Exec=ppsspp
+Version=1.0
+Name=PPSSPP (SDL)
+Exec=ppsspp-sdl %f
Icon=ppsspp
Type=Application
+GenericName=PSP Emulator
Comment=ppsspp (fast and portable PSP emulator)
Categories=Game
diff --git a/games/ppsspp/ppsspp.info b/games/ppsspp/ppsspp.info
index ba5368b1bc7..3021609a004 100644
--- a/games/ppsspp/ppsspp.info
+++ b/games/ppsspp/ppsspp.info
@@ -1,20 +1,18 @@
PRGNAM="ppsspp"
-VERSION="1.9.4"
+VERSION="1.10.3"
HOMEPAGE="https://www.ppsspp.org/"
-DOWNLOAD="https://github.com/hrydgard/ppsspp/archive/v1.9.4/ppsspp-1.9.4.tar.gz \
- https://github.com/hrydgard/glslang/archive/f9d08a25fbe17e0677a89d398f4d7f232339c3f9/hrydgard-glslang-2.3.r2575.gf9d08a25.tar.gz \
- https://github.com/hrydgard/ppsspp-lang/archive/a95fd4974c436a1a07455c5beef4a12f9f47b811/hrydgard-ppsspp-lang-a95fd4974c436a1a07455c5beef4a12f9f47b811.tar.gz \
- https://github.com/KhronosGroup/SPIRV-Cross/archive/a1f7c8dc8ea2f94443951ee27003bffa562c1f13/KhronosGroup-SPIRV-Cross-2019.05.20.r60.ga1f7c8dc.tar.gz \
- https://github.com/Kingcom/armips/archive/7885552b208493a6a0f21663770c446c3ba65576/Kingcom-armips-v0.9.r134.g7885552.tar.gz \
- https://github.com/hrydgard/ppsspp-ffmpeg/archive/90701640c7f458461310b54e7d4041230e2d5d5a/hrydgard-ppsspp-ffmpeg-90701640c7f458461310b54e7d4041230e2d5d5a.tar.gz \
- https://github.com/libretro/libretro-super/raw/master/dist/info/ppsspp_libretro.info"
-MD5SUM="3ba5323553084e48ef9af82ec7802e4a \
- a1847ce9e91631969d61bb552c33df1f \
- c7955acb139ccfcf0b14cd7440e88581 \
- 9c0141380c98ccdff95a084ac07d1d48 \
- 4731977e287eee39ddcc247d75095758 \
- c4906081083ee74e3792da166db69b11 \
- 74e1105d45779d3ae32acaea085ee99e"
+DOWNLOAD="https://github.com/hrydgard/ppsspp/archive/v1.10.3/ppsspp-1.10.3.tar.gz \
+ https://github.com/hrydgard/glslang/archive/d0850f875ec392a130ccf00018dab458b546f27c/glslang-d0850f875ec392a130ccf00018dab458b546f27c.tar.gz \
+ https://github.com/hrydgard/ppsspp-lang/archive/1c64b8fbd3cb6bd87935eb53f302f7de6f86e209/ppsspp-lang-1c64b8fbd3cb6bd87935eb53f302f7de6f86e209.tar.gz \
+ https://github.com/KhronosGroup/SPIRV-Cross/archive/a1f7c8dc8ea2f94443951ee27003bffa562c1f13/SPIRV-Cross-a1f7c8dc8ea2f94443951ee27003bffa562c1f13.tar.gz \
+ https://github.com/Kingcom/armips/archive/7885552b208493a6a0f21663770c446c3ba65576/armips-7885552b208493a6a0f21663770c446c3ba65576.tar.gz \
+ https://github.com/hrydgard/ppsspp-ffmpeg/archive/55147e5f33f5ae4904f75ec082af809267122b94/ppsspp-ffmpeg-55147e5f33f5ae4904f75ec082af809267122b94.tar.gz"
+MD5SUM="66d6f34bba99f06e4cedf8d24fc9a205 \
+ 781915370eb2b2c3c2f75d33a46154ae \
+ 78e170cb8e40106dc1d428f896defdd9 \
+ 9c0141380c98ccdff95a084ac07d1d48 \
+ 4731977e287eee39ddcc247d75095758 \
+ d529fc6f45fd4bbec825c543dab9da65"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="SDL2 python3"
diff --git a/games/ppsspp/ppsspp_libretro.information b/games/ppsspp/ppsspp_libretro.information
deleted file mode 100644
index b9d6c7815bd..00000000000
--- a/games/ppsspp/ppsspp_libretro.information
+++ /dev/null
@@ -1,19 +0,0 @@
-display_name = "Sony - PlayStation Portable (PPSSPP)"
-authors = "Henrik Hrydgard"
-supported_extensions = "elf|iso|cso|prx|pbp"
-corename = "PPSSPP"
-manufacturer = "Sony"
-categories = "Emulator"
-systemname = "PSP"
-systemid = "playstation_portable"
-database = "Sony - PlayStation Portable"
-license = "GPLv2"
-permissions = ""
-display_version = "Git"
-supports_no_game = "false"
-firmware_count = 1
-firmware0_desc = "ppge_atlas.zim (PPSSPP Data ROM)"
-firmware0_path = "PPSSPP/ppge_atlas.zim"
-firmware0_opt = "false"
-notes = "(!) ppge_atlas.zim (md5): a93fc411c1ce7d001a2a812643c70085|(!) PPSSPP requires the asset files, lang folder, and flash0 folder inside the 'system\PPSSPP' directory.|(!) Check https://docs.libretro.com/library/ppsspp/#bios to find out how to get the assets files."
-required_hw_api = "OpenGL Core >= 3.1 | OpenGL ES >= 2.0 | Vulkan >= 1.0 | Direct3D11 >= 11.0"